Modify

Opened 6 years ago

Closed 6 years ago

#10796 closed defect (worksforme)

Kernel Panic when Routing > 8 MB via IPv6

Reported by: wswartzendruber@… Owned by: developers
Priority: high Milestone:
Component: kernel Version: 10.03.1
Keywords: ipv6 6in4 panic Cc:

Description

This is on a Linksys WRT54Gv2

  1. Flash stock openwrt-wrt54g-squashfs.bin via TFTP (10.03.1, brcm47xx)
  2. Add computer's ~/.ssh/id_rsa.pub to router's /etc/dropbear/authorized_keys
  3. passwd
  4. opkg update
  5. opkg install 6in4 radvd wide-dhcpv6-server ip6tables
  6. SCP my old configuration from RC6 to /tmp/ and untar it.
  7. /etc/init.d/firewall disable
  8. /etc/init.d/uhttpd disable
  9. /etc/init.d/usb disable
  10. /etc/init.d/iptables enable <-- My own iptables.
  11. /etc/init.d/ip6tables enable <- Alo my own.

Disabling ip6tables didn't do anything for me. Downloading large amounts of data directly to the router results in smooth operation over IPv6. But downloading through it to another machine over IPv6 causes a kernel panic at around 9 MB of downloading.

Attachments (3)

router-ds-config-20120115-public.tar (20.0 KB) - added by wswartzendruber@… 6 years ago.
Configuration applied to router
openwrt_crash_log_(2011-01-16).txt (14.7 KB) - added by wswartzendruber@… 6 years ago.
/sys/kernel/debug/crashlog
crashlog_2011-01-27.txt (12.5 KB) - added by anonymous 6 years ago.
crashlog from a similarly configured WRT54GS

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by wswartzendruber@…

Configuration applied to router

Changed 6 years ago by wswartzendruber@…

/sys/kernel/debug/crashlog

comment:1 Changed 6 years ago by wswartzendruber@…

I would also like to add that this same thing happened when building everything I needed directly into the image and disabling opkg.

Changed 6 years ago by anonymous

crashlog from a similarly configured WRT54GS

comment:2 Changed 6 years ago by anonymous

For what it's worth, I can't reproduce this on recent trunk (r29915)

comment:3 Changed 6 years ago by sfkoch@…

Are you sure your crash is only caused by IPv6 traffic? I got a very similar crash after upgrading my WRT54Gv2 to 10.03.1, but I hadn't even set ipv6 up on the new install yet. The traffic that seemed to trigger the crash for me was ipv4. I made a post about it on the forum: https://forum.openwrt.org/viewtopic.php?id=35295

comment:4 Changed 6 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.