Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10758 closed defect (fixed)

Ath5k on Ar5212 minipci card in client keeps on disconncting

Reported by: anonymous Owned by: developers
Priority: response-needed Milestone: Barrier Breaker 14.07
Component: packages Version: 10.03.1
Keywords: Cc:

Description

Running Ath5k driver on a AR5212 minipci card in client mode under download result in disconnection from ap
have to manually make it connect by issuing the wifi command when this happen
is there a solution to fix this problem.....
NOTE : TO REPRODUCE ONE HAVE TO DOWNLOAD HEAVYIE(TORRENTS OR DIRECT DOWNLOAD WILL HAPPEN IN SECONDS)
THE KERNEL LOG IS FLOODED WITH THIS ERROR

dmesg
wlan0: associate with 00:02:61:47:35:a3 (try 1)
wlan0: RX ReassocResp from 00:02:61:47:35:a3 (capab=0x431 status=0 aid=1)
wlan0: associated
wlan0: authenticate with 00:02:61:47:35:a3 (try 1)
wlan0: authenticated.........(FLOODED)

Attachments (0)

Change History (16)

comment:1 Changed 6 years ago by nbd

  • Priority changed from highest to response-needed

Please try latest trunk

comment:2 Changed 6 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

comment:3 Changed 6 years ago by anonymous

  • Resolution no_response deleted
  • Status changed from closed to reopened

finally ndb !!!

i made all those post about ath5k long time ago but it remained unanswered so i didn't look into it always....

i saw in the changelog that ath5k has recieved some new patches currently compiling a image from latest backfire revision 10.03.1

ps the orginal problem was that in client managed mode the client gets disconnected when heavy traffic occurs (torrent download)

wlan0: associate with 00:02:61:47:35:a3 (try 1)
wlan0: RX ReassocResp from 00:02:61:47:35:a3 (capab=0x431 status=0 aid=1)
wlan0: associated
wlan0: authenticate with 00:02:61:47:35:a3 (try 1)
wlan0: authenticated.........(FLOODED)

comment:4 Changed 6 years ago by nbd

Don't try 10.03.1, try latest trunk or backfire svn.

comment:5 Changed 6 years ago by anonymous

sorry i maeant svn.....
okay tried backfire svn at revision r30752 problem persist i had setup the router in repeater mode ap+sta

first test- it was connected to another ap in station mode and brodcasted ap with thte same

the connection was very unstable it kept deauthenticating and authenticating with client and also pc would lose connection to repeated ap
here is the kernel log

wlan0-1: deauthenticating from 00:02:61:47:35:a3 by local choice (reason=3)
wlan0: authenticate with 00:02:61:47:35:a3 (try 1)
wlan0: authenticated
wlan0: associate with 00:02:61:47:35:a3 (try 1)
wlan0: RX AssocResp from 00:02:61:47:35:a3 (capab=0x431 status=0 aid=1)
wlan0: associated

second test in only client mode removed ap it did the same

br-lan: port 2(wlan0) entering disabled state
wlan0-1: deauthenticating from 00:02:61:47:35:a3 by local choice (reason=3)
wlan0: authenticate with 00:02:61:47:35:a3 (try 1)
wlan0: authenticated
wlan0: associate with 00:02:61:47:35:a3 (try 1)
wlan0: RX AssocResp from 00:02:61:47:35:a3 (capab=0x431 status=0 aid=1)
wlan0: associated
wlan0: authenticate with 00:02:61:47:35:a3 (try 1)
wlan0: authenticated
wlan0: associate with 00:02:61:47:35:a3 (try 1)
wlan0: RX ReassocResp from 00:02:61:47:35:a3 (capab=0x431 status=0 aid=1)
wlan0: associated
wlan0: deauthenticated from 00:02:61:47:35:a3 (Reason: 2)
wlan0: authenticate with 00:02:61:47:35:a3 (try 1)
wlan0: authenticated
wlan0: associate with 00:02:61:47:35:a3 (try 1)
wlan0: RX ReassocResp from 00:02:61:47:35:a3 (capab=0x431 status=0 aid=1)
wlan0: associated

should i try trunk now

thanks for all your help nbd

comment:6 Changed 6 years ago by anonymous

additional information i am running openwrt on a x86 platform with a atheros ar5212 mini pci card a/b/g some other problem i noticed

by default openwrt sets incorrect power output the card power output is set to 27dbm 501mw this is wrong as this card is only capable of 20dbm 100mw

comment:7 Changed 6 years ago by anonymous

the problem also persist in trunk ..... i have found the deauth auth in trunk is much less

i have tried changing encryption on ap router to
wep and wpa2 with the same results

comment:8 Changed 6 years ago by anonymous

i think the problem is specific to the x86 kernel please excuse me if i sound stupid...

comment:9 Changed 6 years ago by anonymous

ath5k is very slow and buggy on ar5212 mini pci card on a x86 platform

I frequently get disconnected with
THE KERNEL LOG IS FLOODED WITH THIS ERROR

dmesg
wlan0: associate with 00:02:61:47:35:a3 (try 1)
wlan0: RX ReassocResp from 00:02:61:47:35:a3 (capab=0x431 status=0 aid=1)
wlan0: associated
wlan0: authenticate with 00:02:61:47:35:a3 (try 1)
wlan0: authenticated.........(FLOODED)[/code]

madwifi has way much better throughout but i get the following errors flooded with it

wifi0: ath_chan_set: Unable to reset channel 6 (2437 MHz) flags 0xd0 'Hardware d respond as expected' (HAL status 3)
wifi0: ath_chan_set: Unable to reset channel 6 (2437 MHz) flags 0xd0 'Hardware d respond as expected' (HAL status 3)
wifi0: ath_chan_set: Unable to reset channel 6 (2437 MHz) flags 0xd0 'Hardware d respond as expected' (HAL status 3)

comment:10 Changed 6 years ago by anonymous

if you guys think my ar5212 card might be faulty i checked in windows with windows driver and it works fine....

comment:11 Changed 6 years ago by anonymous

i also tried ddwrt x86 version on my platform which is based on the madiwifi driver and it works rock solid none of the above errors

comment:12 Changed 6 years ago by anonymous

anything ????
the same problem occue in ubuntu

comment:13 Changed 6 years ago by anonymous

what more information to provide ???

comment:14 Changed 6 years ago by anonymous

just an update running the same mini pci card on latest ubuntu debian 11.10 run's very stable with no problem i did not check the version of the ath5k wireless driver though......

comment:15 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

should be fixed in latest trunk

comment:16 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.