Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10753 closed defect (fixed)

LUCI/UCI return an error when trying to set 'restrict Masquerading ...'

Reported by: John Allen <zzz2002@…> Owned by:
Priority: normal Milestone: Barrier Breaker 14.07
Component: luci Version: Trunk
Keywords: masq_src masq_dest Cc:

Description

LUCI/UCI returns 'One or more fields contain invalid values!' when trying to set 'Restrict Masquerading to given ...'.
The problem show up with both the source and destination fields.

Attachments (1)

LUCI_BUG.jpg (81.8 KB) - added by John Allen <zzz2002@…> 6 years ago.
luci screen shot

Download all attachments as: .zip

Change History (8)

comment:1 follow-up: Changed 6 years ago by jow

Using which values?

Changed 6 years ago by John Allen <zzz2002@…>

luci screen shot

comment:2 in reply to: ↑ 1 Changed 6 years ago by John Allen <zzz2002@…>

Replying to jow:

Using which values?

My interfaces were configured as follows
dmz 74.116.186.177/28
lan 192.168.30.1/27
guest 192.168.30.1/28

I tried several values, some examples that I remember were
192.168.1.1
192.168.1.1/28
192.168.20.1/28
192.168.20.1/28 192.168.30.1/27
!74.116.186.177/28

comment:3 Changed 6 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

This should be fixed with http://luci.subsignal.org/trac/changeset/8154 .
If you already run recent LuCI trunk on your router, you can hot-patch it with:

wget -O/usr/lib/lua/luci/model/cbi/firewall/zone-details.lua \
  http://luci.subsignal.org/trac/export/8154/luci/trunk/applications/luci-firewall/luasrc/model/cbi/firewall/zone-details.lua

comment:4 Changed 6 years ago by John Allen <zzz2002@…>

That seems to have fixed the problem.

Thanks

John Allen

comment:5 Changed 6 years ago by John Allen <zzz2002@…>

  • Resolution fixed deleted
  • Status changed from closed to reopened

Sorry to be the bearer of bad tidings, but the problem is back with

r29697 + LUCI trunk + svn8168.

equipment is WNDR3700v2.

comment:6 Changed 6 years ago by jow

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.