Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10737 closed defect (worksforme)

TP-L 841ND-V7 get bricked after new patch

Reported by: desigabri Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: brick stuck 841 uboot Cc:

Description

Hi, there is the need to patch again the

"trunk/target/linux/ar71xx/image/Makefile" of the 29658 patch

because uboot doesn't know the tp-l841nd-v7 and the router became bricked.

Needs serial to fix.

tryed to change back the definition to the TL-WR741ND board and all start working again.

#tlwr841v7_cmdline=board=TL-WR841N-v7 console=ttyS0,115200

tlwr841v7_cmdline=board=TL-WR741ND console=ttyS0,115200

I'm sure about it: I compiled two different firmwares after patch 29658, flashed via web, sysupgrade and serial, every time bricked (see the logs under here).

[    0.000000] Linux version 2.6.39.4 (desigabri@desigabri-ubuntu11) (gcc version 4.6.2 20110813 (prerelease) (Linaro GCC 4.6-2011.08) ) #59 Thu Jan 5 00:42:41 CET 2012
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 00019374 (MIPS 24Kc)
[    0.000000] SoC: Atheros AR7241 rev 1
[    0.000000] Clocks: CPU:400.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:5.000MHz
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 02000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone PFN ranges:
[    0.000000]   Normal   0x00000000 -> 0x00002000
[    0.000000] Movable zone start PFN for each node
[    0.000000] early_node_map[1] active PFN ranges
[    0.000000]     0: 0x00000000 -> 0x00002000
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
[    0.000000] Kernel command line:  board=TL-WR841N-v7 console=ttyS0,115200 rootfstype=squashfs,jffs2 noinitrd
[    0.000000] MIPS: no machine found for id 'TL-WR841N-v7', supported machines:
[    0.000000] id                       name
[    0.000000] Generic                  Generic AR71xx board
[    0.000000] ALL0258N                 Allnet ALL0258N
[    0.000000] AP121-MINI               Atheros AP121-MINI
[    0.000000] AP121                    Atheros AP121
[    0.000000] AP81                     Atheros AP81
[    0.000000] AP83                     Atheros AP83
[    0.000000] AP96                     Atheros AP96
[    0.000000] AW-NR580                 AzureWave AW-NR580
[    0.000000] DB120                    Atheros DB120
[    0.000000] DIR-600-A1               D-Link DIR-600 rev. A1
[    0.000000] DIR-615-C1               D-Link DIR-615 rev. C1
[    0.000000] DIR-825-B1               D-Link DIR-825 rev. B1
[    0.000000] EAP7660D                 Senao EAP7660D
[    0.000000] JA76PF                   jjPlus JA76PF
[    0.000000] JWAP003                  jjPlus JWAP003
[    0.000000] HORNET-UB                ALFA NETWORKS Hornet-UB
[    0.000000] MZK-W04NU                Planex MZK-W04NU
[    0.000000] MZK-W300NH               Planex MZK-W300NH
[    0.000000] NBG460N                  Zyxel NBG460N/550N/550NH
[    0.000000] OM2P                     OpenMesh OM2P
[    0.000000] PB42                     Atheros PB42
[    0.000000] PB44                     Atheros PB44
[    0.000000] PB92                     Atheros PB92
[    0.000000] 493G                     MikroTik RouterBOARD 493G
[    0.000000] 493                      MikroTik RouterBOARD 493/AH
[    0.000000] 450G                     MikroTik RouterBOARD 450G
[    0.000000] 450                      MikroTik RouterBOARD 450
[    0.000000] 433U                     MikroTik RouterBOARD 433UAH
[    0.000000] 433                      MikroTik RouterBOARD 433/AH
[    0.000000] 411U                     MikroTik RouterBOARD 411U
[    0.000000] 411                      MikroTik RouterBOARD 411/A/AH
[    0.000000] 750i                     MikroTik RouterBOARD 750
[    0.000000] TEW-632BRP               TRENDnet TEW-632BRP
[    0.000000] TL-MR3420                TP-LINK TL-MR3420
[    0.000000] TL-MR3220                TP-LINK TL-MR3220
[    0.000000] TL-WA901ND               TP-LINK TL-WA901ND
[    0.000000] TL-WA901ND-v2            TP-LINK TL-WA901ND v2
[    0.000000] TL-WR741ND               TP-LINK TL-WR741ND
[    0.000000] TL-WR741ND-v4            TP-LINK TL-WR741ND v4
[    0.000000] TL-WR841N-v1.5           TP-LINK TL-WR841N v1
[    0.000000] TL-WR941ND               TP-LINK TL-WR941ND
[    0.000000] TL-WR1043ND              TP-LINK TL-WR1043ND
[    0.000000] TL-WR703N                TP-LINK TL-WR703N v1
[    0.000000] UBNT-XM                  Ubiquiti UniFi
[    0.000000] UBNT-AR                  Ubiquiti AirRouter
[    0.000000] UBNT-NM                  Ubiquiti Nanostation M
[    0.000000] UBNT-RM                  Ubiquiti Rocket M
[    0.000000] UBNT-BM                  Ubiquiti Bullet M
[    0.000000] UBNT-LS-SR71             Ubiquiti LS-SR71
[    0.000000] UBNT-LSX                 Ubiquiti LSX
[    0.000000] UBNT-RSPRO               Ubiquiti RouterStation Pro
[    0.000000] UBNT-RS                  Ubiquiti RouterStation
[    0.000000] WHR-HP-GN                Buffalo WHR-HP-GN
[    0.000000] WHR-G301N                Buffalo WHR-G301N
[    0.000000] WHR-HP-G300N             Buffalo WHR-HP-G300N
[    0.000000] WNDR3700                 NETGEAR WNDR3700/WNDR3800/WNDRMAC
[    0.000000] WNR2000                  NETGEAR WNR2000
[    0.000000] WP543                    Compex WP543
[    0.000000] WRT160NL                 Linksys WRT160NL
[    0.000000] WRT400N                  Linksys WRT400N
[    0.000000] WZR-HP-G300NH            Buffalo WZR-HP-G300NH
[    0.000000] WZR-HP-G300NH2           Buffalo WZR-HP-G300NH2
[    0.000000] WZR-HP-AG300H            Buffalo WZR-HP-AG300H
[    0.000000] WZR-HP-G450H             Buffalo WZR-HP-G450H
[    0.000000] ZCN-1523H-5              Zcomax ZCN-1523H-5
[    0.000000] ZCN-1523H-2              Zcomax ZCN-1523H-2
[    0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[    0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 29356k/32768k available (2018k kernel code, 3412k reserved, 396k data, 184k init, 0k highmem)
[    0.000000] SLUB: Genslabs=9, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:80
[    0.000000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
[    0.080000] pid_max: default: 32768 minimum: 301
[    0.080000] Mount-cache hash table entries: 512
[    0.090000] NET: Registered protocol family 16
[    0.100000] MIPS: machine is Generic AR71xx board
[    0.110000] bio: create slab <bio-0> at 0
[    0.110000] Switching to clocksource MIPS
[    0.120000] NET: Registered protocol family 2
[    0.120000] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.130000] TCP established hash table entries: 1024 (order: 1, 8192 bytes)
[    0.140000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.140000] TCP: Hash tables configured (established 1024 bind 1024)
[    0.150000] TCP reno registered
[    0.150000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.160000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.160000] NET: Registered protocol family 1
[    0.190000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.190000] JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.200000] msgmni has been set to 57
[    0.210000] io scheduler noop registered
[    0.210000] io scheduler deadline registered (default)
[    0.220000] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[    0.240000] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A
[    0.250000] console [ttyS0] enabled, bootconsole disabled
[    0.250000] console [ttyS0] enabled, bootconsole disabled
[    0.260000] Atheros AR71xx SPI Controller driver version 0.2.4
[    0.270000] Atheros AR71xx hardware watchdog driver version 0.1.0
[    0.280000] TCP westwood registered
[    0.290000] NET: Registered protocol family 17
[    0.290000] 802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
[    0.300000] All bugs added by David S. Miller <davem@redhat.com>
[    0.300000] VFS: Cannot open root device "(null)" or unknown-block(0,0)
[    0.310000] Please append a correct "root=" boot option; here are the available partitions:
[    0.320000] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)


Attachments (0)

Change History (11)

comment:1 follow-up: Changed 6 years ago by dyq <729650915@…>

use 'make clean' then retry again

comment:2 in reply to: ↑ 1 ; follow-up: Changed 6 years ago by desigabri

Replying to dyq <729650915@…>:

use 'make clean' then retry again

As I wrote it isn't a compiling trouble. The bootloader doesn't recognize the model because it does not exist.

Kernel command line: board=TL-WR841N-v7 console=ttyS0,115200 rootfstype=squashfs,jffs2 noinitrd
MIPS: no machine found for id 'TL-WR841N-v7', 

supported machines: 

... 
TL-MR3420                TP-LINK TL-MR3420
TL-MR3220                TP-LINK TL-MR3220
TL-WA901ND               TP-LINK TL-WA901ND
TL-WA901ND-v2            TP-LINK TL-WA901ND v2
TL-WR741ND               TP-LINK TL-WR741ND
TL-WR741ND-v4            TP-LINK TL-WR741ND v4
TL-WR841N-v1.5           TP-LINK TL-WR841N v1
TL-WR941ND               TP-LINK TL-WR941ND
TL-WR1043ND              TP-LINK TL-WR1043ND
TL-WR703N                TP-LINK TL-WR703N v1
...

As it was before (it worked before and it still works now), just the need to define the new TP-L WR841ND-v7 definition like the TP-L WR741ND and the bootloader doesn't stop anymore.

This isn't a question, I tryed it and it works, because the bootloader needs to read about a known type to go ahead or any others patch that developers can apply.

It works in this way (with the same previous troubles but it works) and after the 29658 patch it bricks.

So I resolved my problems, this is the trick, I only thought for people problems about the need to debrick their router trougth serial cable and wrote as soon as it was possible to advice developers about it.

Anyway yes, I could be in error, but really it seems to me to be right about this

comment:3 follow-up: Changed 6 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed

The changeset is not the problem. The problem is that you didn't make target/linux/clean, so the updated mach files didn't get compiled into your kernel. Thats really a local build issue, not a bug.

Your own paste shows that your own kernel lacks the "TL-WR841N-v7" which was clearly added to mach-tl-mr3x20.c, line 146.

comment:4 in reply to: ↑ 2 ; follow-up: Changed 6 years ago by dyq <729650915@…>

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Replying to desigabri:

Replying to dyq <729650915@…>:

use 'make clean' then retry again

As I wrote it isn't a compiling trouble. The bootloader doesn't recognize the model because it does not exist.

Kernel command line: board=TL-WR841N-v7 console=ttyS0,115200 rootfstype=squashfs,jffs2 noinitrd
MIPS: no machine found for id 'TL-WR841N-v7', 

supported machines: 

... 
TL-MR3420                TP-LINK TL-MR3420
TL-MR3220                TP-LINK TL-MR3220
TL-WA901ND               TP-LINK TL-WA901ND
TL-WA901ND-v2            TP-LINK TL-WA901ND v2
TL-WR741ND               TP-LINK TL-WR741ND
TL-WR741ND-v4            TP-LINK TL-WR741ND v4
TL-WR841N-v1.5           TP-LINK TL-WR841N v1
TL-WR941ND               TP-LINK TL-WR941ND
TL-WR1043ND              TP-LINK TL-WR1043ND
TL-WR703N                TP-LINK TL-WR703N v1
...

As it was before (it worked before and it still works now), just the need to define the new TP-L WR841ND-v7 definition like the TP-L WR741ND and the bootloader doesn't stop anymore.

This isn't a question, I tryed it and it works, because the bootloader needs to read about a known type to go ahead or any others patch that developers can apply.

It works in this way (with the same previous troubles but it works) and after the 29658 patch it bricks.

So I resolved my problems, this is the trick, I only thought for people problems about the need to debrick their router trougth serial cable and wrote as soon as it was possible to advice developers about it.

Anyway yes, I could be in error, but really it seems to me to be right about this

target/linux/ar71xx/config-2.6.39
add
'CONFIG_AR71XX_MACH_TL_WR841N_V7=y'
after
'CONFIG_AR71XX_MACH_TL_WR941ND=y'

comment:5 in reply to: ↑ 4 Changed 6 years ago by juhosg

  • Resolution set to worksforme
  • Status changed from reopened to closed

Replying to dyq <729650915@…>:

Replying to desigabri:

Replying to dyq <729650915@…>:

use 'make clean' then retry again

As I wrote it isn't a compiling trouble. The bootloader doesn't recognize the model because it does not exist.

Kernel command line: board=TL-WR841N-v7 console=ttyS0,115200 rootfstype=squashfs,jffs2 noinitrd
MIPS: no machine found for id 'TL-WR841N-v7', 

supported machines: 

... 
TL-MR3420                TP-LINK TL-MR3420
TL-MR3220                TP-LINK TL-MR3220
TL-WA901ND               TP-LINK TL-WA901ND
TL-WA901ND-v2            TP-LINK TL-WA901ND v2
TL-WR741ND               TP-LINK TL-WR741ND
TL-WR741ND-v4            TP-LINK TL-WR741ND v4
TL-WR841N-v1.5           TP-LINK TL-WR841N v1
TL-WR941ND               TP-LINK TL-WR941ND
TL-WR1043ND              TP-LINK TL-WR1043ND
TL-WR703N                TP-LINK TL-WR703N v1
...

As it was before (it worked before and it still works now), just the need to define the new TP-L WR841ND-v7 definition like the TP-L WR741ND and the bootloader doesn't stop anymore.

This isn't a question, I tryed it and it works, because the bootloader needs to read about a known type to go ahead or any others patch that developers can apply.

It works in this way (with the same previous troubles but it works) and after the 29658 patch it bricks.

So I resolved my problems, this is the trick, I only thought for people problems about the need to debrick their router trougth serial cable and wrote as soon as it was possible to advice developers about it.

Anyway yes, I could be in error, but really it seems to me to be right about this

target/linux/ar71xx/config-2.6.39
add
'CONFIG_AR71XX_MACH_TL_WR841N_V7=y'
after
'CONFIG_AR71XX_MACH_TL_WR941ND=y'

No new kernel configuration option has been introduced, so this is not needed. A simple 'make target/linux/clean world' must work.

comment:6 Changed 6 years ago by desigabri

Ok, tonight I'll try your way. I believed to be right because before compiling I did a "make clean" because I switched from GCC4.5 Linaro to GCC4.6;
I didn't do a "make target/linux/clean world" because I'm not so smart to know all tricks.

Anyway I wrote about the BOOTLOADER message: I thought the problem depended about it because I recompiled again the same trunk without my correction and another time I got the trouble.
I'll see, thanks

comment:7 Changed 6 years ago by desigabri

I have to say that really I don't know anything more then a bit... :((

I apologize and I say soory about that. All you wrote is true. No troubles and no error messages after "make clean world".

I didn't apply this

target/linux/ar71xx/config-2.6.39
add
'CONFIG_AR71XX_MACH_TL_WR841N_V7=y'
after
'CONFIG_AR71XX_MACH_TL_WR941ND=y'

anyway all went right

comment:8 Changed 6 years ago by desigabri

sorry: make target/linux clean world

comment:9 in reply to: ↑ 3 Changed 6 years ago by dk

Replying to jow:

The changeset is not the problem. The problem is that you didn't make target/linux/clean, so the updated mach files didn't get compiled into your kernel. Thats really a local build issue, not a bug.

Your own paste shows that your own kernel lacks the "TL-WR841N-v7" which was clearly added to mach-tl-mr3x20.c, line 146.

Hi.

  1. Does this means that every "svn updtate" we should run "make clean"?
  2. Is there a difference between "make clean" and "make target/linux/clean"?

Greets

comment:10 Changed 6 years ago by jow

It mrans that you should clean your kernel whenever the per-target files change.

comment:11 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.