Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10728 closed defect (fixed)

pulseaudio can't start with default configuration

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

I'm having trouble to start pulseaudio:

root@OpenWrt:~# ps | grep pulse

1912 root 1184 S grep pulse

root@OpenWrt:~# /etc/init.d/pulseaudio start
E: [pulseaudio] main.c: Daemon startup failed.

I tried some other ways to start the daemon (without --daemonize):
root@OpenWrt:~# /usr/bin/pulseaudio --system --disallow-exit --disallow-module-loading --disable-sh
m --exit-idle-time=-1
W: [pulseaudio] main.c: OK, so you are running PA [...] bad idea.
E: [pulseaudio] main.c: Daemon startup without any loaded modules, refusing to work.

Is there something wrong with the default setup?

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by jow

It should work after installing udev. Looks like that this is needed to satisfy /usr/lib/pulse-1.1/modules/module-udev-detect.so which apparently fails to load if /lib/libudev.so isn't present - yay pulseaudio.

It should probably be made a conditional compilation dependency.

comment:2 Changed 6 years ago by loswillios

  • Resolution set to fixed
  • Status changed from new to closed

fixed with r29715, thanks for reporting.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.