Modify

Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#10713 closed defect (duplicate)

/dev/random does not produce data

Reported by: flyn Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: kernel random RB493G Cc:

Description

On trunk (revision 29632) on a RB493G, the kernel does not seem to generate enough entropy for /dev/random to produce data. This prevents the krb5kdc (Kerberos) service from running because "kdb5_util create -s" hangs while it attempts to generate random data.

Also, cat /dev/random does not print anything.

/dev/urandom works fine. In fact, linking /dev/urandom to /dev/random allows "kdb5_util create -s" to complete, but this does not have sufficient cryptographic properties.

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by hnyman <hannu.nyman@…>

Looks like a duplicate of #9631

comment:2 Changed 5 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.