Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10708 closed defect (wontfix)

TP-LINK WR1043ND Unstable Wireless with 802.11g+n and WEP

Reported by: Rudy Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: 10.03.1
Keywords: Cc:

Description

TP-LINK WR1043ND running Backfire 10.03.1 has unstable wireless connection when choosing WEP encryption and 802.11g+n.

Turning off WEP encryption stabilizes the connection.

Alternatively, selecting 802.11g operation stabilizes the connection as well.

The problem occurs with multiple clients: Dell X300 w/ Intel Wireless 2200BG card, Ipod, Ipad, PS3, Wii.

Stock firmware has no problem.

Attachments (0)

Change History (4)

comment:1 follow-up: Changed 6 years ago by jow

  • Resolution set to wontfix
  • Status changed from new to closed

The ciphers used by WEP and WPA1 are unsuitable for frame aggregation and thus degrade 11n performance a lot. This is by design and cannot be fixed.

comment:2 in reply to: ↑ 1 Changed 6 years ago by anonymous

Replying to jow:

The ciphers used by WEP and WPA1 are unsuitable for frame aggregation and thus degrade 11n performance a lot. This is by design and cannot be fixed.

Consider that the /dev/random bug on atheros builds may increase the performance degrade too.

comment:3 Changed 6 years ago by anonymous

If you know, what the consequences are, please try if running /sbin/wifi returns warning concerning /dev/random.
If so, try deleting /dev/random, link /dev/urandom to /dev/random and run wifi again.
Now test your connection using the old settings. Please report back!

comment:4 Changed 4 years ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.