Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10707 closed defect (duplicate)

OperationalError: database is locked

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

How to Reproduce

While doing a POST operation on /newticket, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'924796644d274b0c7550234d',
 'author': u'tarun01@netzero.net',
 'field_cc': u'',
 'field_component': u'packages',
 'field_description': u"i tried latest 10.03.1  and after the flash access to luci.\r\ninstalled ixp4xx-generic on actiontec mi424wr  rev C from 10.03.1  ''\r\n\r\n\r\n",
 'field_keywords': u'MI424WR rev C, ',
 'field_milestone': u'',
 'field_priority': u'high',
 'field_summary': u'backfire 10.03.1  on IXP4xx    luci is not accessable ',
 'field_type': u'defect',
 'field_version': u'10.03.1',
 'submit': u'Create ticket'}

User Agent was: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.24) Gecko/20111107 Ubuntu/10.04 (lucid) Firefox/3.6.24

System Information

Trac 0.11.7
Python 2.6.2 (release26-maint, Apr 19 2009, 01:58:18)
[GCC 4.3.3]
setuptools 0.6c9
SQLite 3.6.10
pysqlite 2.5.0
Genshi 0.5.1
Pygments 0.10
Subversion 1.6.1 (r37116)
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/trac/web/main.py", line 450, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.6/dist-packages/trac/web/main.py", line 206, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.6/dist-packages/trac/ticket/web_ui.py", line 183, in process_request
    return self._process_newticket_request(req)
  File "/usr/lib/python2.6/dist-packages/trac/ticket/web_ui.py", line 397, in _process_newticket_request
    valid = self._validate_ticket(req, ticket)
  File "/usr/lib/python2.6/dist-packages/trac/ticket/web_ui.py", line 989, in _validate_ticket
    for field, message in manipulator.validate_ticket(req, ticket):
  File "build/bdist.linux-x86_64/egg/tracspamfilter/adapters.py", line 78, in validate_ticket
    FilterSystem(self.env).test(req, author, changes, ip)
  File "build/bdist.linux-x86_64/egg/tracspamfilter/api.py", line 168, in test
    score, ['%s (%d): %s' % r for r in reasons]).insert()
  File "build/bdist.linux-x86_64/egg/tracspamfilter/model.py", line 141, in insert
    db.commit()
OperationalError: database is locked


Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by jow

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #10451

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.