Modify

Opened 6 years ago

Closed 4 years ago

#10700 closed defect (worksforme)

kernel oops during "rm -r" of large directory

Reported by: Lars Wijtemans <openwrt@…> Owned by: developers
Priority: normal Milestone:
Component: base system Version: 10.03.1
Keywords: Cc:

Description

I'm consistently getting a kernel oops when I try to delete the mailroot used by the xmail package, which is located on external storage by means of pivot overlay.

Let me start by saying that I do not have a lot of experience with bug reporting, the Linux kernel, OpenWrt, nor with reading oopses. So things might be wrong.

This occurs with 10.03.1 and r29608 of the Backfire branch (latest) on a TL-WR1043ND.

Steps to reproduce:

  • Start with fresh install
  • Install extroot packages
  • Set up primary partition with ext4 filesystem on external USB attached storage to serve as extroot
  • Set up the extroot and reboot
  • Install xmail package
  • Create a directory on the external storage to serve as mailroot
  • Unpack /etc/MailRoot.tar.bz2 to your mailroot
  • Start xmail /etc/init.d/xmail start
  • Stop xmail /etc/init.d/xmail stop
  • Try to remove the mailroot directory rm -r /mail/xmail/*

It has always resulted in a kernel oops, with a few variations here and there. It seems to choke on the spool subdirectory, which has quite a lot of subdirectories itself. Sometimes the system keeps running, sometimes it causes multiple oopses, resulting in a kernel panic and reboot. It does screw things up though, as subsequent calls to rm just hang until a SIGINT is sent.

When you reboot without extroot and mount the filesystem, rm works just fine. So it seems it has something to do with the overlay system (mini_fo), which also shows up in the Call trace.

Without swap

CPU 0 Unable to handle kernel paging request at virtual address 00806914, epc == 800d7a30, ra == 800ed190

With swap on lvm2 logical volume on external storage

Unhandled kernel unaligned access[#1]:

Call trace of backfire/10.03.1/ar71xx/openwrt-ar71xx-tl-wr1043nd-v1-squashfs-factory.bin image

[<800ed190>] 0x800ed190
[<800e32e4>] 0x800e32e4
[<800e26a4>] 0x800e26a4
[<800e4238>] 0x800e4238
[<80131588>] 0x80131588
[<8012d060>] 0x8012d060
[<801319d8>] 0x801319d8
[<80131588>] 0x80131588
[<800ed190>] 0x800ed190
[<800e30e8>] 0x800e30e8
[<800e4cbc>] 0x800e4cbc
[<81b86280>] 0x81b86280
[<800e56c8>] 0x800e56c8
[<81b97ad8>] 0x81b97ad8
[<800e58e0>] 0x800e58e0
[<800e631c>] 0x800e631c
[<800e3e88>] 0x800e3e88
[<800de1e8>] 0x800de1e8
[<800e5d28>] 0x800e5d28
[<800de2a4>] 0x800de2a4
[<800d816c>] 0x800d816c
[<800e7b20>] 0x800e7b20
[<800d8224>] 0x800d8224
[<80062544>] 0x80062544

Call trace of Backfire r29608

[<800d8378>] kmem_cache_alloc+0x4c/0xc4
[<800eda6c>] d_alloc+0x34/0x194
[<800e3bf0>] __lookup_hash+0xfc/0x160
[<800e4b40>] lookup_one_len+0xd0/0x100
[<8012dc04>] mini_fo_lookup+0x184/0x8f8
[<800e39f4>] do_lookup+0xe0/0x1e0
[<800e55c4>] __link_path_walk+0xa34/0x10fc
[<800e5fd0>] path_walk+0x88/0x14c
[<800e61e8>] do_path_lookup+0x34/0x6c
[<800e6c24>] user_path_at+0x5c/0xa8
[<800deb10>] vfs_fstatat+0x3c/0x7c
[<800debcc>] sys_lstat64+0x20/0x48
[<80062544>] stack_done+0x20/0x3c

Full oops

root@gw:/# rm -rf /var/mail/xmail
Unhandled kernel unaligned access[#1]:
Cpu 0
$ 0   : 00000000 00000001 00000000 a0814bca
$ 4   : a0814bb2 a0814bba 00000000 800eda6c
$ 8   : 00000072 41664667 48453339 6b744633
$12   : 00000000 00000000 00000000 0000000a
$16   : a0814b8a a0814be2 81b8fc90 814b87ff
$20   : 80320000 00000000 814b8300 00000004
$24   : 00000001 00000000
$28   : 81b8e000 81b8fc28 00000000 800edad8
Hi    : 00000000
Lo    : 0000005b
epc   : 800edb4c d_alloc+0x114/0x194
    Not tainted
ra    : 800edad8 d_alloc+0xa0/0x194
Status: 1000dc03    KERNEL EXL IE
Cause : 00800010
BadVA : 814b87ff
PrId  : 00019374 (MIPS 24Kc)
Modules linked in: sg nf_nat_tftp nf_conntrack_tftp nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack pppoe pppox ipt_REJECT xt_TCPMSS ipt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables ppp_async ppp_generic slhc loop dm_crypt dm_mirror dm_region_hash dm_log dm_mod ath9k ath9k_common ath9k_hw ath mac80211 crc_ccitt cfg80211 compat sha256_generic sha1_generic des_generic arc4 aes_generic deflate ecb cbc usb_storage ohci_hcd ehci_hcd sd_mod ext4 jbd2 usbcore scsi_mod nls_base mbcache crc16 leds_gpio button_hotplug gpio_buttons input_polldev input_core
Process rm (pid: 1529, threadinfo=81b8e000, task=81815b30, tls=00000000)
Stack : 81b8e000 81b8fc50 802a58d3 00000000 fffffffe 00000000 81e926e8 814b87ff
        81b8fc90 800e3bf0 802a58d3 00000001 81e926e8 800e2fb0 00000000 802a58d3
        00000000 00000000 814b87ff 00000017 00000000 800e4b40 00000000 00000000
        0000027b 80320000 23cb950d 00000017 802a58bc 8012e344 802a0000 814b87ff
        00000000 814b87ff 814f2230 80129e1c 81e926e8 00000000 80fcdd80 8012e794
        ...
Call Trace:
[<800edb4c>] d_alloc+0x114/0x194
[<800e3bf0>] __lookup_hash+0xfc/0x160
[<800e4b40>] lookup_one_len+0xd0/0x100
[<80129e1c>] meta_build_lists+0xcc/0x388
[<8012e344>] mini_fo_lookup+0x8c4/0x8f8
[<800e39f4>] do_lookup+0xe0/0x1e0
[<800e55c4>] __link_path_walk+0xa34/0x10fc
[<800e5fd0>] path_walk+0x88/0x14c
[<800e61e8>] do_path_lookup+0x34/0x6c
[<800e6c24>] user_path_at+0x5c/0xa8
[<800deb10>] vfs_fstatat+0x3c/0x7c
[<800debcc>] sys_lstat64+0x20/0x48
[<80062544>] stack_done+0x20/0x3c


Code: 8e620000  2c420001  00028036 <c2620000> 24420001  e2620000  1040001a  00000000  8e630038
Disabling lock debugging due to kernel taint
Segmentation fault

Attachments (6)

wrt.0.err (4.1 KB) - added by Lars Wijtemans <openwrt@…> 6 years ago.
kernel oops on r29608 with swap
wrt.1.err (2.5 KB) - added by Lars Wijtemans <openwrt@…> 6 years ago.
kernel oops on r29608 with swap
wrt.2.err (11.6 KB) - added by Lars Wijtemans <openwrt@…> 6 years ago.
kernel oops on r29608 with swap
wrt.3.err (9.2 KB) - added by Lars Wijtemans <openwrt@…> 6 years ago.
kernel oops on r29608 with swap
wrt.backfire-10.03.1-ar71xx-wr1043nd.1.err (7.2 KB) - added by Lars Wijtemans <openwrt@…> 6 years ago.
kernel oops on 10.03.1 with swap
wrt.backfire-10.03.1-ar71xx-wr1043nd.0.err (9.1 KB) - added by Lars Wijtemans <openwrt@…> 6 years ago.
kernel oops on 10.03.1 without swap

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by Lars Wijtemans <openwrt@…>

kernel oops on r29608 with swap

Changed 6 years ago by Lars Wijtemans <openwrt@…>

kernel oops on r29608 with swap

Changed 6 years ago by Lars Wijtemans <openwrt@…>

kernel oops on r29608 with swap

Changed 6 years ago by Lars Wijtemans <openwrt@…>

kernel oops on r29608 with swap

Changed 6 years ago by Lars Wijtemans <openwrt@…>

kernel oops on 10.03.1 with swap

Changed 6 years ago by Lars Wijtemans <openwrt@…>

kernel oops on 10.03.1 without swap

comment:1 Changed 4 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

works in current versions

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.