Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10664 closed defect (fixed)

umurmur-openssl can't load library 'libpolarssl.so.0'

Reported by: Nilfred <nilfred@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: umurmur umurmurd openssl polarssl libpolarssl Cc:

Description

umurmurd (umurmur-openssl) does not start because can't load library 'libpolarssl.so.0'

It comes in 2 flavors: -openssl and -polarssl, but -openssl flavor still require polarssl?

opkg install umurmur-openssl
...
/etc/init.d/umurmur start
/usr/bin/umurmurd: can't load library 'libpolarssl.so.0'
opkg list-installed | grep ssl
libopenssl - 1.0.0e-1
umurmur-openssl - 0.2.8-1

Tested workaround:

opkg install libpolarssl
...
/etc/init.d/umurmur start
opkg list-installed | grep -e 'ssl\|-r'
base-files - 98-r29473
libopenssl - 1.0.0e-1
libpolarssl - 1.0.0-1
umurmur-openssl - 0.2.8-1

Platform information:

grep Hardware /proc/cpuinfo 
Hardware        : Netgear WNR854T
uname -sr
Linux 3.0.12

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by martin@…

uMurmur's build system changed between 0.2.6 to 0.2.8 to autoconf-based. Default is to build against PolarSSL. See ticket #10287 for how to fix this.

comment:2 Changed 6 years ago by swalker

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r29891.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.