Modify

Opened 6 years ago

Closed 4 years ago

Last modified 4 years ago

#10662 closed defect (fixed)

Avahi-daemon

Reported by: anonymous Owned by: developers
Priority: low Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

avahi-daemon is missing deps;
libdbus, librt, dbus

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by mikebrady@…

I don't understand what the problem is here -- I think the dependencies are all in place, as explained below:

avahi-daemon depends on libavahi.
Libavahi has dependencies to libpthread which in turn depends on librt, so they will be both be included as dependencies.

avahi-daemon does not normally depend on dbus. IN fact, it only depends on dbus and libdbus if it is built with dbus support. In that case, libavahi must be built with dbus support too. Dbus support is enabled by selecting libavahi-dbus-support. Libavahi-dbus-support has a dependency to the dbus package, including libdbus. Thus, dbus and libdbus will be included as dependencies if you select dbus support for avahi.

Or am I missing something?

M.

comment:2 Changed 4 years ago by Mike Brady <mikebrady@…>

I believe this is fixed. I'd be grateful if you'd close the ticket.

comment:3 Changed 4 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.