Modify

Opened 6 years ago

Last modified 4 years ago

#10621 new defect

Uses source IP of wrong interface

Reported by: negativeiq@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

The situation is as follows:
A TP-LINK WR-1043ND running Backfire 10.03.1 is connected to the Internet via PPPoE and runs an OpenVPN tunnel to another device which has its own network behind it.
The router is configured to use WPA2/802.1X where the Radius server is located on the other side of the OpenVPN tunnel, which means that access requests should be sent on the tunnel interface.
Usually this works - However occasionally a very odd situation occurs in which the requests are still sent on the tunnel interface but with the source IP of the WAN interface (!!) - Something that should never happen.
Note that only Radius requests seem to have this issue - other communication through the tunnel works fine. So far the only way I found to fix this issue is to restart the router.
Attached are a tcpdump capture of the tunnel interface taken on the router itself as well as an ifconfig dump.

Attachments (1)

attach.tar.bz2 (2.5 KB) - added by negativeiq@… 6 years ago.
tcpdump and ifconfig as described in the ticket.

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by negativeiq@…

tcpdump and ifconfig as described in the ticket.

comment:1 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.