Modify

Opened 6 years ago

Last modified 4 years ago

#10602 new defect

Xorg fonts cannot be used as packages because of unneccessary font-util dependency

Reported by: rossb@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

These xorg related packages: encodings, font-alias, font-misc-misc, font-bh-75dpi, font-cursor-misc, font-daewoo-misc, font-dec-misc, font-ibm-type1, font-isas-misc, font-jis-misc, font-micro-misc, font-misc-cyrillic, font-xfree86-type1 are problematic as modules. 

When the above packages are attempted to install, they fail because of missing font-util dependency.

font-util is not built as a package, it is a host tool and does not exist as a package, preventing module dependency satisfaction.

Solution:

In Makefiles, for all above enumerated packages, do this:

  SUBMENU:=font
-  DEPENDS:= +xserver +font-util @DISPLAY_SUPPORT
+  DEPENDS:= +xserver @DISPLAY_SUPPORT
+  PKG_BUILD_DEPENDS:=font-util
  TITLE:=

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.