Modify

Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#10579 closed defect (obsolete)

Can't set up SSH to use LAN interface only in easy ways at 1st attempt.

Reported by: i8080 Owned by:
Priority: normal Milestone: Barrier Breaker 14.07
Component: luci Version: Trunk
Keywords: Cc:

Description

Configuration:

Backfire 10.03.1 RC6 on RouterStation.

To reproduce:

  1. Install OpenWRT in a clean way. It should be 1st run where OpenWRT starts with defaults (JFFS just formatted, no root password, etc).
  2. Enter LuCI web face.
  3. Specify root password, etc. Save and apply as usually.
  4. Configure network. I'm using more or less typical DHCP on WAN and static IP on LAN. Save and apply changes again.
  5. Now go to System -> Administration on LuCI.
  6. Select "lan" as interface. Save and apply changes again.
  7. Try to access device via LAN using SSH.


Result:

Connection refused.


Expected:

SSH should bind to LAN interface and allow access with password set at step 3.

Workaround:

SSH will work as expected after several re-configurations of this feature via luci webface (somesthing like LAN -> save & apply -> unspecified -> save & apply -> LAN again -> save&apply -> works as expected).

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed

I was unable to reproduce this, I assume your network wasn't fully up when you did that, or you attempted to connect via IPv6 (explicitely or implicitely)

comment:2 Changed 6 years ago by i8080

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I was able to test (and reproduce) this on at least 2 platforms so far: brcm47xx (WL500GP) and AR71xx (RouterStation). Official squashfs images were used.

  1. What do you mean - "not fully up"? Router haves static IP and runs DHCP so it should be up very fast an if network interface on remote computer is down or hasnt't got IP I would have some error but it can't be "connection refused" at all. Actually, "connection refused" confirms that network was UP, desired IP was present but daemon has refused to listen on proper interface and port for some reason.


  1. As for IPv6, neither default image appears to support IPv6 in it's default state, nor I had a chance to use it since I specified explicit IPv4 addresses of devices. So this version if fairly doubtful. Furthermore, even if all this was true, and IPv6 got up, daemon should listen on IPv6 assigned to LAN interface if I specify "LAN" in web face, isn't it?


  1. Granted that after couple of changes to this setting things are starting to work as expected and no other changes, it looks like if 1st attempt to apply new settings isn't successful for some reason.

comment:3 Changed 5 years ago by nbd

  • Resolution set to obsolete
  • Status changed from reopened to closed

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.