Modify

Opened 6 years ago

Closed 3 years ago

#10570 closed defect (not_a_bug)

DHCP packet received on interface which has no address

Reported by: dumghen Owned by: cyrus
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: dhcp network Cc:

Description

OpenWrt daemon.warn dnsmasq-dhcp[1854]: DHCP packet received on eth0.1 which has no address

Linux OpenWrt 3.0.3 #1 Sun Nov 20 00:15:23 MST 2011 mips GNU/Linux

ATTITUDE ADJUSTMENT (bleeding edge, r29262)

brcm47xx, Broadcom, ASUS WL500gP v2

Attachments (0)

Change History (31)

comment:1 Changed 6 years ago by danielkza2@…

I have this issue in a WR-1043ND running the latest trunk (r29570). I tried some of the solutions mentioned in forum threads (adding the WAN interface manually to the ignore list in /etc/config/network, disabling bridging) to no avail.

comment:2 Changed 6 years ago by danielkza2@…

Read /etc/config/dhcp instead of /etc/config/network in the comment above.

comment:3 Changed 6 years ago by turbidit@…

The same problem on dir-320. Option 'list notinterface' does not work.

comment:4 Changed 6 years ago by anonymous

I have this issue in a TL WR-1043ND running the latest trunk (r32775).

...
Jul 19 08:15:48 openwrt daemon.warn dnsmasq-dhcp[2943]: DHCP packet received on eth0.2 which has no address
Jul 19 08:16:04 openwrt daemon.warn dnsmasq-dhcp[2943]: DHCP packet received on eth0.2 which has no address
Jul 19 08:16:19 openwrt daemon.warn dnsmasq-dhcp[2943]: DHCP packet received on eth0.2 which has no address
...

/etc/config/dhcp:

config 'dnsmasq'
    list 'notinterface' 'eth0.2'
    ...
config 'dhcp' 'wan'
    option 'interface' 'wan'
    option 'ignore' '1'
    ...

It works fine on r32739, but it is useless to r32775.

comment:5 Changed 6 years ago by jow

  • Owner changed from developers to acinonyx
  • Status changed from new to assigned

comment:6 Changed 6 years ago by acinonyx

  • Resolution set to fixed
  • Status changed from assigned to closed

Should be fixed in r32781

comment:7 Changed 5 years ago by stonecarver@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

Running RC1 on TL WR-941 ND v3 still getting this message in system log

Dec 1 18:25:43 OpenWrt daemon.warn dnsmasq-dhcp[1596]: DHCP packet received on wan which has no address

DHCP
etc/config/dhcp:
config dnsmasq

option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
list notinterface 'wan'

config dhcp 'wan'

option interface 'wan'
option ignore '1'

NETWORK
config interface 'loopback'

option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'

option ifname 'lan1 lan2 lan2 lan3 lan4'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.1.1'


config interface 'wan'

option ifname 'wan'
option _orig_ifname 'wan'
option _orig_bridge 'false'
option proto 'pppoe'
option username '*'
option password '
*'


comment:8 Changed 5 years ago by Nilfred <nilfred@…>

I can confirm never had the problem in r32012 (TL-MR3220), but start to appear a few days after I set cron:

25 6 * * * /sbin/ifup wan && /usr/bin/logger -p cron.info -t network "Scheduled WAN reconnect" >/dev/null 2>&1

Then the bug is immune to '/etc/init.d/network reload' even to '/etc/init.d/network restart' only full reboot solves the issue.
Only affects wireless DHCP request, wired ones works.

It happened once in another router r32910 (TL-WR1043ND) which also has:

27 6 * * * /usr/bin/logger -p cron.info -t network "Scheduled WAN reconnect" && /etc/init.d/network reload >/dev/null 2>&1

Later replaced reload for restart and finally removed the cron entry recently when upgraded to 12.09-rc1 (r34185)

I didn't report before because it looks so unrelated :-/
(My ISP hang up pppoe at exactly 22 hs of dial up. The hang up may happen in a bad moment in a few days, so the daily reconnect prevent those wrathful moments.)

comment:9 Changed 5 years ago by lord_i

It see like no correct work of /etc/init.d/dnmasq script
I add this string in /etc/dnsmasq.conf:
except-interface=eth0.2
and slove this problem...

comment:10 Changed 5 years ago by anonymous

I can confirm adding except-interface=wan to /etc/dnsmasq.conf solved my problem.

comment:11 Changed 5 years ago by karmazin@…

Tp-Link 1043ND 12.09-rc1

Jan 3 19:14:01 OpenWrt daemon.warn dnsmasq-dhcp[1357]: DHCP packet received on eth0.2 which has no address
Jan 3 19:14:08 OpenWrt daemon.warn dnsmasq-dhcp[1357]: DHCP packet received on eth0.2 which has no address
Jan 3 19:14:10 OpenWrt daemon.warn dnsmasq-dhcp[1357]: DHCP packet received on eth0.2 which has no address

DHCP
etc/config/dhcp:
config dnsmasq

config dnsmasq

option domainneeded 1
option boguspriv 1
option filterwin2k 0 # enable for dial on demand
option localise_queries 1
option rebind_protection 1 # disable if upstream must serve RFC1918 addresses
option rebind_localhost 1 # enable for RBL checking and similar services
#list rebind_domain example.lan # whitelist RFC1918 responses for domains
option local '/lan/'
option domain 'lan'
option expandhosts 1
option nonegcache 0
option authoritative 1
option readethers 1
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
#list server '/mycompany.local/1.2.3.4'
#option nonwildcard 1
#list interface br-lan
#list notinterface lo
#list bogusnxdomain '64.94.110.11'

config dhcp lan

option interface lan
option start 150
option limit 200
option leasetime 24h

config dhcp wan

option interface wan
option ignore 1

comment:12 follow-up: Changed 5 years ago by lord_i

add this string in /etc/dnsmasq.conf:
except-interface=eth0.2
and restart router.
This slove your problem.

comment:13 Changed 5 years ago by anonymous

thx

comment:14 in reply to: ↑ 12 Changed 5 years ago by shippo@…

Replying to lord_i:

add this string in /etc/dnsmasq.conf:
except-interface=eth0.2
and restart router.
This slove your problem.

Works for me, thanks for the info.
In case you don't want to ruin your uptime (like me ;-) you can reload the dnsmasq config instead of restarting the router:

/etc/init.d/dnsmasq reload

comment:15 Changed 5 years ago by nbd

  • Resolution set to not_a_bug
  • Status changed from reopened to closed

comment:16 Changed 4 years ago by philip_petev

  • Resolution not_a_bug deleted
  • Status changed from closed to reopened

The issue appears again on TP-Link TL-WR1043ND V1 with BB r40820+ My log is flooded with lines like this one:

Fri Jun  6 11:04:58 2014 daemon.warn dnsmasq-dhcp[1731]: DHCP packet received on eth0.2 which has no address

Adding except-interface=eth0.2 to /etc/dnsmasq.conf and list 'notinterface' 'eth0.2' to /etc/config/dhcp doesn't seems to work.

Last edited 4 years ago by philip_petev (previous) (diff)

comment:17 Changed 4 years ago by anonymous

I have same problem on TL-WR1043ND running Barrier Breaker r40982

comment:18 Changed 4 years ago by anonymous

I have this problem also and none of described workarounds doesn't work.
TP-Link TL-WDR3600 v1,
DISTRIB_ID="OpenWrt"
DISTRIB_RELEASE="Bleeding Edge"
DISTRIB_REVISION="r40846"
DISTRIB_CODENAME="barrier_breaker"
DISTRIB_TARGET="ar71xx/generic"
DISTRIB_DESCRIPTION="OpenWrt Barrier Breaker r40846"

comment:19 Changed 4 years ago by philip_petev

One other thing I've noticed: the bug appears only if the WAN protocol is set to PPPoE. There's no problem on Static/DHCP. Haven't tried other protokols.

comment:20 Changed 4 years ago by philip_petev

I think the problem is in dnsmasq itself. It doesn't obey any settings I've added to /etc/dnsmasq.conf

comment:21 Changed 4 years ago by swalker

  • Owner changed from acinonyx to cyrus
  • Status changed from reopened to assigned

Fallout from r40759's 100-fix-dhcp-no-address-warning.patch removal?

comment:22 Changed 4 years ago by cyrus

  • Resolution set to fixed
  • Status changed from assigned to closed

I reintroduced the patch in r41246.

comment:23 Changed 4 years ago by anonymous

Just tested dnsmasq 2.71-3, no more flood. Thank you!

comment:24 Changed 4 years ago by philip_petev

dnsmasq 2.71-3 now obeys its config file. Thank you !!!

comment:25 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:26 Changed 3 years ago by anonymous

daemon.warn dnsmasq-dhcp[2364]: DHCP packet received on wlan0-1 which has no address

Floods through r42039.

comment:27 Changed 3 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:28 follow-up: Changed 3 years ago by anonymous

daemon.warn dnsmasq-dhcp[2364]: DHCP packet received on wlan0-1 which has no address

Floods through r42039. Using WNDR3800. Default configuration.

comment:29 in reply to: ↑ 28 ; follow-up: Changed 3 years ago by bittorf@…

Replying to anonymous:

daemon.warn dnsmasq-dhcp[2364]: DHCP packet received on wlan0-1 which has no address

Floods through r42039. Using WNDR3800. Default configuration.

there is no "wlan0-1" in default configuration.
also: check if "wlan0-1" has an address.

comment:30 in reply to: ↑ 29 Changed 3 years ago by anonymous

Replying to bittorf@…:

Replying to anonymous:

daemon.warn dnsmasq-dhcp[2364]: DHCP packet received on wlan0-1 which has no address

Floods through r42039. Using WNDR3800. Default configuration.

there is no "wlan0-1" in default configuration.
also: check if "wlan0-1" has an address.

Hmm. Good catch. This might have occurred after I added a guest AP. I suppose it doesn't automagically work out by itself :\

comment:31 Changed 3 years ago by jow

  • Resolution set to not_a_bug
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.