Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10557 closed defect (worksforme)

Extroot dont work

Reported by: cargt3@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Hallo,

I have the problem with extroot. Earlier everything was working fine, but after firstboot, formating pendrive and configuring it again i dont work.
This is my fstab file:

config global automount
	option from_fstab 1
	option anon_mount 1
	
config global autoswap
	option from_fstab 1
	option anon_swap 0
	
config mount
	option target	/overlay
	option device	/dev/sda1
	option fstype	ext3
	option options	rw,sync
	option enabled	1
	option enabled_fsck 0

config swap
	option device	/dev/sda2
	option enabled	0

I have the pendrive with only one ext3 partition.

Attachments (0)

Change History (5)

comment:1 in reply to: ↑ description Changed 6 years ago by anonymous

Replying to cargt3@…:

Hallo,

I have the problem with extroot. Earlier everything was working fine, but after firstboot, formating pendrive and configuring it again i dont work.
This is my fstab file:

config global automount
	option from_fstab 1
	option anon_mount 1
	
config global autoswap
	option from_fstab 1
	option anon_swap 0
	
config mount
	option target	/overlay
	option device	/dev/sda1
	option fstype	ext3
	option options	rw,sync
	option enabled	1
	option enabled_fsck 0

config swap
	option device	/dev/sda2
	option enabled	0

I have the pendrive with only one ext3 partition.

your configuration is not correct, with 'option is_rootfs 1' missing.also, option target /overlay is not needed

comment:2 Changed 6 years ago by anonymous

I asked in the one forum and they tell me my old configuration is incorrect, so i changed it. I used to have configuration what you wrote but it didnt work.

comment:3 Changed 6 years ago by Nilfred <nilfred@…>

I couldn't reproduce the bug. Unplug the pendrive to make changes to fstab. Read the Wiki. Use the forum NOT ticket system. Be sure to include dmesg and mount output.

comment:4 Changed 6 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.