Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10553 closed defect (fixed)

WNDR3700 v1 power LED no longer blinks during startup or solid after boot.

Reported by: AndrewSi@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Something about the recent WNDR3700 reconfiguration has broken the default definition for the power LED. Normally it blinks during boot and is solid thereafter, but after installing r29460 on a v1 device, it's not on at all unless I manually go set the power LED to the on state with the luci page for LED control.

Attachments (0)

Change History (6)

comment:1 Changed 6 years ago by Goofball <goofball222@…>

I'm also experiencing this on r29460. It's orange during the bootloader period and then goes dark and never starts blinking/goes solid green like normal. This persists after a dirclean and menuconfig from scratch.

comment:2 Changed 6 years ago by jmccrohan

I am also experiencing this on an WNDR3700v2. I believe this is as a result of r29434, along with #10554.

comment:3 Changed 6 years ago by John Allen <zzz2002@…>

problem is still there in 29614

comment:4 Changed 6 years ago by Goofball <goofball222@…>

The LED issue appears to have corrected itself for me after doing one of the following in order of severity of cleanup (I'm guessing the kernel cleanup or distclean resolved it). !WARNING! -Make a backup copy of your .config before running distclean:

make dirclean

make target/linux/clean world

make distclean

Additionally I rebuilt .config from scratch to make sure it wasn't something funky with an older format of the file or missing options:

echo CONFIG_TARGET_ar71xx=y > .config
make defconfig

make menuconfig

Prior to flashing the sysupgrade image I edited /etc/config/system on the router and removed all LED references except the following:

config 'led' 'led_usb'
	option 'name' 'USB'
	option 'sysfs' 'wndr3700:green:usb'
	option 'trigger' 'usbdev'
	option 'dev' '1-1'
	option 'interval' '50'
	option 'default' '0'

config 'led' 'led_wan'
	option 'name' 'WAN LED (green)'
	option 'sysfs' 'wndr3700:green:wan'
	option 'default' '0'

I am running r29606 currently.

comment:5 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.