Modify

Opened 6 years ago

Last modified 4 years ago

#10545 reopened defect

USB Automount notworking in trunk

Reported by: Aswin Paranji <aswin.paranji@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Hi,
I have a buffalo WZRg300NH Buffalo router.
the current trunk release does not support USB automount feature. When i checked with the backfire RC6, the automount feature is working. However, this is failing in the trunk.

I have attached the fstab.config file which i have modified for the trunk release.

In addition to this. i do not see block-hotplug available for my router.
Here is the link where i used the opkg to enable USB support for backfire RC6 which is working fine and fails for trunk.

http://www.tolaris.com/2010/09/01/openwrt-10-03-on-buffalo-wzr-hp-g300nh/

can someone help me on this.

Attachments (1)

block.diff (369 bytes) - added by Aswin Paranji <aswin.paranji@…> 6 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 follow-up: Changed 6 years ago by jow

  • Resolution set to invalid
  • Status changed from new to closed

This is no support forum. Please only open tickets if you have more substantial information than "it does not work".

comment:2 in reply to: ↑ 1 Changed 6 years ago by anonymous

Replying to jow:

This is no support forum. Please only open tickets if you have more substantial information than "it does not work".

jow,

thanks for responding back. I understand that this is not a forum. Based on information such as block-hotplug not available in trunk but it is available in backfire RC6, i have opened the ticket.

when i tried to install block-hotplug, i see package unavailable message.
i have been using trunk for a while and 4 weeks before block-hotplug and usb mounting was working. today when i updated to the latest trunk version. i lost support for USB. please let me know if you need more information.

comment:3 follow-up: Changed 6 years ago by jow

No block-hostplug, block-extroot and block-mount are all merged into block-mount .
Now you talk about lost USB support while the initial problem was about missing block-hotplug, so what *is* the actual issue now?

comment:4 in reply to: ↑ 3 Changed 6 years ago by Aswin Paranji <aswin.paranji@…>

The problem is USB drive is not mounting when it is plugged in to the router. i have attached my fstab.init file. the fstab uses drive label to mount a particular drive on to a folder. when i do a manual mount, it is mounting. however, automount is not working. i have also enabled the mount by label/uuid in busy box settings.

The reason i brought block-hotplug is that it was available in backfire. From the information you have provided it is understood that the block-hotplug has been merged to block-mount.

The USB mount based on label was working 6 to 7 weeks ago.
i'll also do a dist clean and check again.

comment:5 Changed 6 years ago by Aswin Paranji <aswin.paranji@…>

  • Resolution invalid deleted
  • Status changed from closed to reopened

Hi,

i have narrowed down the problem to 'blkid' inside the script block.sh. it seems when the blkid is executed, it returns empty value due to which label or UUID fails to mount.

However, if the blkid is executed with path(/usr/sbin/blkid), it prints the information.

i have attached the file diff.

Let me know if my analysis right.

Thanks,
Aswin Paranji

Changed 6 years ago by Aswin Paranji <aswin.paranji@…>

comment:6 Changed 6 years ago by jow

Do you have two blkid (Busybox applet + extra package) or is it just not finding the command?

comment:7 Changed 6 years ago by Aswin Paranji <aswin.paranji@…>

Yes, there are 2 blkid being selected. whats the difference between the blkid in busy box and the one is "Utilities/Filesystem". i thought blkid in busy box needs to be selected.

Can this be merged into single blkid?

Thanks

comment:8 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.