Modify

Opened 6 years ago

Last modified 3 years ago

#10536 reopened defect

luci-app-statistics - trunk+svn7976-1 - assert

Reported by: anonymous Owned by:
Priority: response-needed Milestone: Barrier Breaker 14.07
Component: luci Version: Trunk
Keywords: statistics, luci Cc:

Description

/usr/lib/lua/luci/dispatcher.lua:449: Failed to execute call dispatcher target for entry '/admin/statistics/graph/interface'.
The called action terminated with an exception:
/usr/lib/lua/luci/util.lua:221: attempt to get length of local 'str' (a nil value)
stack traceback:

[C]: in function 'assert'
/usr/lib/lua/luci/dispatcher.lua:449: in function 'dispatch'
/usr/lib/lua/luci/dispatcher.lua:195: in function </usr/lib/lua/luci/dispatcher.lua:194>

Attachments (0)

Change History (17)

comment:1 in reply to: ↑ description Changed 6 years ago by anonymous

Attitude Adjustment (r29337)

Replying to anonymous:

/usr/lib/lua/luci/dispatcher.lua:449: Failed to execute call dispatcher target for entry '/admin/statistics/graph/interface'.
The called action terminated with an exception:
/usr/lib/lua/luci/util.lua:221: attempt to get length of local 'str' (a nil value)
stack traceback:

[C]: in function 'assert'
/usr/lib/lua/luci/dispatcher.lua:449: in function 'dispatch'
/usr/lib/lua/luci/dispatcher.lua:195: in function </usr/lib/lua/luci/dispatcher.lua:194>

comment:2 Changed 6 years ago by anonymous

I dont see this issue in latest build

comment:3 Changed 6 years ago by Valent Turkovic <valent.turkovic@…>

I'm also seeing this issue. Can I help to troubleshoot this issue somehow?

comment:4 Changed 6 years ago by Valent Turkovic <valent.turkovic@…>

Found issue in network plugin configuration, if you have this:

<Plugin network>

Server "239.192.74.66" "25826"

</Plugin>

then it breaks whole luci-app-statistics

When I removed Server option luci-app-statistics started working again!

comment:5 Changed 6 years ago by Valent Turkovic <valent.turkovic@…>

This happened again on another openwrt instance and even with the most sparse collectd config I still get this error, why?!?

It worked 2 days ago and I didn't update, install or change anything related to luci-statirstics

comment:6 Changed 6 years ago by jow

I need more context for the error above. Paste the source code of the surrounding html as well.

comment:7 Changed 6 years ago by Valent Turkovic <valent.turkovic@…>

I can give you root ssh access and luci root access to this router, just don't break it ;)
Please mail me and I'll email you info.

comment:8 Changed 6 years ago by jow

  • Priority changed from low to response-needed
  • Resolution set to worksforme
  • Status changed from new to closed

I believe the issue is due to a) broken /etc/config/luci_statistics or b) missing permissions for the "nobody" user to read /etc/config/ or /etc/config/luci_statistics

comment:9 Changed 6 years ago by Valent Turkovic <valent.turkovic@…>

  • Resolution worksforme deleted
  • Status changed from closed to reopened

This is a clean install of openwrt so any broken permissions are in firmware, but this looks like some other issue.

I tried chmod 755 on /etc/config and /etc/config/luci_statistics and restarting luci_statistics and collectd services, still no luck :(

I can see that collectd is gathering data:
# du -h /tmp/igreguric/
64.0K /tmp/igreguric/cpu-0
32.0K /tmp/igreguric/memory
40.0K /tmp/igreguric/iwinfo-wlan0
72.0K /tmp/igreguric/processes-dropbear
76.0K /tmp/igreguric/processes-dnsmasq
24.0K /tmp/igreguric/ping
16.0K /tmp/igreguric/load
76.0K /tmp/igreguric/processes-uhttpd
56.0K /tmp/igreguric/processes
88.0K /tmp/igreguric/tcpconns-22-local
88.0K /tmp/igreguric/tcpconns-80-local
8.0K /tmp/igreguric/conntrack
640.0K /tmp/igreguric/

Just the graphing part is broken somehow.

Here are config files, luci_statistics - http://pastebin.com/AbUHW2mC and collectd.conf - http://pastebin.com/4BC9iYpL

comment:10 Changed 5 years ago by spam.dump.one@…

I have this error too.

Last time it appeared after changing the RRDTool storage directory to an external drive.
Files get created, but graphing reports that error.

I'm on the latest stable release, using WNDR3800.

comment:11 Changed 4 years ago by anonymous

Still not working in barrier breaker trunk

Model	TP-Link TL-WDR4900 v1
Firmware Version	 OpenWrt Barrier Breaker r39161 / LuCI Trunk (svn-r9945)
Kernel Version	3.10.24

Error:

/usr/lib/lua/luci/dispatcher.lua:448: Failed to execute call dispatcher target for entry '/admin/statistics/graph/load'.
The called action terminated with an exception:
/usr/lib/lua/luci/util.lua:209: attempt to get length of local 'str' (a nil value)
stack traceback:
	[C]: in function 'assert'
	/usr/lib/lua/luci/dispatcher.lua:448: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:195: in function </usr/lib/lua/luci/dispatcher.lua:194>

comment:12 follow-up: Changed 4 years ago by anonymous

solved:

chmod 755 /etc/config/luci_statistics

comment:13 in reply to: ↑ 12 Changed 4 years ago by Dmitri Bogomolov <4glitch@…>

Replying to anonymous:

solved:

chmod 755 /etc/config/luci_statistics

This helped for me too. But this is a workaround, not fix.

comment:14 Changed 4 years ago by anonymous

same happens to me,

chmod 644 /etc/config/luci_statistics

helps
but, every time i change "Collectd Settings" it's broken an i have to set chmod again.

comment:15 Changed 4 years ago by anonymous

It seems that uci is the culprit /ticket/14942.html

comment:16 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:17 Changed 3 years ago by jacek_j@…

Hi,

I get similar error:

/usr/lib/lua/luci/dispatcher.lua:448: Failed to execute call dispatcher target for entry '/admin/statistics/graph/memory'.
The called action terminated with an exception:
/usr/lib/lua/luci/util.lua:209: attempt to get length of local 'str' (a nil value)
stack traceback:
	[C]: in function 'assert'
	/usr/lib/lua/luci/dispatcher.lua:448: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:195: in function </usr/lib/lua/luci/dispatcher.lua:194>

My system:

TP-Link TL-WR2543N/ND v1
LuCI Trunk (0.12+svn-r10530) OpenWrt Barrier Breaker 14.07

Installed collectd packages:

# opkg list-installed *collect*
collectd - 4.10.8-3
collectd-mod-cpu - 4.10.8-3
collectd-mod-interface - 4.10.8-3
collectd-mod-iwinfo - 4.10.8-3
collectd-mod-load - 4.10.8-3
collectd-mod-memory - 4.10.8-3
collectd-mod-network - 4.10.8-3
collectd-mod-rrdtool - 4.10.8-3

chmod (chmod 755 /etc/config/luci_statistics) don't solve my problem

I'm not sure if this is important but rrd files are stored at overlay (filesystem is ext4, data are stored in /collectd/ directory)

All configuration was created via web interface.

Best regard,

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.