Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10535 closed defect (fixed)

Boost 1.46.0 fails to build

Reported by: aswin.paranji@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Hi,
when the bosst library is included it fails to compile for buffalo router.

By changing the makefile to include the following line, the compilation happens properly.
cflags='-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time -fhonour-copts -msoft-float' \

Could some one add this to the trunk.
Thanks,
Aswin Paranji

Attachments (2)

Makefile (7.7 KB) - added by aswin.paranji@… 6 years ago.
boost.makefile.patch (843 bytes) - added by zhenglei@… 6 years ago.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by aswin.paranji@…

Changed 6 years ago by zhenglei@…

comment:1 Changed 6 years ago by anonymous

The problem is caused by missing quotes when configuring gcc for boost build. See boost.makefile.patch for a proper fix. Hope this can get into the trunk soon.

comment:2 Changed 6 years ago by swalker

  • Resolution set to fixed
  • Status changed from new to closed

Thanks, fixed in r29873.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.