Opened 6 years ago

Last modified 3 years ago

#10521 reopened defect

file system corruption on x86 usb stick ext2

Reported by: normunds Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Backfire 10.03.1 RC5
Keywords: Cc:


running openwrt on x86 usb pen stick. the sda2 partition gets corrupte d for no reasons. lots of inode errors and the file system always shows unclean no matter there is clean boot. Changed the owrt (backfire) version but problem was always there. changed the pendrive but no problem resolved. Tried squashfs but it wont boot. No way to clean the root partition.

Attachments (0)

Change History (6)

comment:1 Changed 5 years ago by nordi

I hab the same trouble, can anyone give some tips?

comment:2 Changed 5 years ago by nbd

  • Resolution set to too_vague
  • Status changed from new to closed

if the problem is still present, please reopen with more details, including the kernel log with the actual error messages

comment:3 Changed 4 years ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

comment:4 Changed 3 years ago by M95D

  • Resolution too_vague deleted
  • Status changed from closed to reopened

I'm running OpenWRT Attitude Adjustment r36088 on Asus WL-500gP (brcm-47xx).

This is the putty log showing the problem:

root@OpenWrt:/# mkfs.ext2 /dev/sda1
mke2fs 1.42.4 (12-June-2012)
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=0 blocks, Stripe width=0 blocks
57600 inodes, 230399 blocks
11519 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=239075328
8 block groups
32768 blocks per group, 32768 fragments per group
7200 inodes per group
Superblock backups stored on blocks:

32768, 98304, 163840, 229376

Allocating group tables: done
Writing inode tables: done
Writing superblocks and filesystem accounting information: done

root@OpenWrt:/# mount /dev/sda1
root@OpenWrt:/# cd /mnt/usb
root@OpenWrt:/mnt/usb# ls
root@OpenWrt:/mnt/usb# touch USB
root@OpenWrt:/mnt/usb# tar -C /overlay -cvf - . | tar -C /mnt/usb -xf -

(a long list of files here; no errors)

root@OpenWrt:/mnt/usb# rm JFFS
root@OpenWrt:/mnt/usb# ls
USB etc lib lost+found mnt root sbin usr www
root@OpenWrt:/mnt/usb# sync
root@OpenWrt:/mnt/usb# umount /dev/sda1
umount: can't umount /mnt/usb: Device or resource busy
root@OpenWrt:/mnt/usb# cd ..
root@OpenWrt:/mnt# umount /dev/sda1
root@OpenWrt:/mnt# e2fsck /dev/sda1
e2fsck 1.42.4 (12-June-2012)
/dev/sda1: clean, 528/57600 files, 5980/230399 blocks
root@OpenWrt:/mnt# e2fsck -f /dev/sda1
e2fsck 1.42.4 (12-June-2012)
Pass 1: Checking inodes, blocks, and sizes
Inode 7 has illegal block(s). Clear<y>?

(followed by a very long list of errors)

comment:5 Changed 3 years ago by nbd

Please test Barrier Breaker or trunk.

comment:6 Changed 3 years ago by M95D

I tried to test latest snapshot, but it didn't have a web interface.

Barrier Breaker r42625:
I followed the same commands as above and similar errors showed up.

Also, is it normal for jffs to show this in log?
[ 11.710000] jffs2: notice: (251) jffs2_build_xattr_subsystem: complete building xattr subsystem, 19 of xdatum (1 unchecked, 18 orphan) and 86 of xref (0 dead, 19 orphan) found.

Add Comment

Modify Ticket

as reopened .

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.