Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10512 closed defect (worksforme)

Openvpn not working on r29341

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: openvpn Cc:

Description

For certain reason openvpn is not working on newest version. No error message in the system log and no openvpn log was created. It looked like it's not reading /etc/config/openvpn at all.

There are different between older version of /etc/init.d/openvpn. I copied the /etc/init.d/openvpn from the older build but still did not work. However the old /etc/init.d/openvpn reads the /etc/config/openvpn file and put the following error message in the /tmp/openvpn.log file.

Options error: --ifconfig-pool/--ifconfig-pool-persist requires --mode server

Attachments (1)

openvpn.txt (1.1 KB) - added by anonymous 6 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 follow-ups: Changed 6 years ago by jow

Please attach the output of "uci export openvpn"

comment:2 in reply to: ↑ 1 Changed 6 years ago by anonymous

Replying to jow:

Please attach the output of "uci export openvpn"

There's no openvpn entry in uci

root@OpenWrt openvpn# uci export openvpn
uci: Parse error (invalid command) at line 6, byte 0

comment:3 Changed 6 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed

So you have a syntax error in your /etc/config/openvpn and the issue is operator error.

comment:4 in reply to: ↑ 1 Changed 6 years ago by anonymous

Replying to jow:

Please attach the output of "uci export openvpn"

I removed the comment lines that start with ; and the following is the result for uci export openvpn

root@OpenWrt config# uci export openvpn
package 'openvpn'

config 'openvpn' 'lan'

option 'enable' '1'
option 'port' '1194'
option 'proto' 'udp'
option 'dev' 'tun'
option 'ca' '/etc/openvpn/ca.crt'
option 'cert' '/etc/openvpn/server.crt'
option 'key' '/etc/openvpn/server.key'
option 'dh' '/etc/openvpn/dh1024.pem'
option 'script_security' '2'
option 'ifconfig_pool_persist' '/tmp/ipp.txt'
option 'keepalive' '10 60'
option 'comp_lzo' '1'
option 'persist_key' '1'
option 'persist_tun' '1'
option 'status' '/tmp/openvpn-status.log'
option 'log' '/tmp/openvpn.log'
option 'verb' '3'
option 'user' 'nobody'
option 'group' 'nogroup'
option 'client_connect' '/etc/openvpn/client_connect.sh'
option 'client_to_client' '1'
option 'server' '10.8.0.0 255.255.255.0'
option 'client_config_dir' '/etc/openvpn/clients'
list 'push' 'dhcp-option DNS 10.8.0.1'
list 'push' 'route 192.168.3.0 255.255.255.0'
list 'route' '192.168.0.0 255.255.255.0'

Changed 6 years ago by anonymous

comment:5 Changed 6 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Just realized the ticket was closed. It wasn't syntax error. I removed the old comment lines that started with ; and uci export openvpn output the openvpn settings. Unfortunately, it's still not working after /etc/init.d/openvpn restart. Same as before, no error message, no log and no openvpn process.

comment:6 Changed 6 years ago by jow

  • Resolution set to worksforme
  • Status changed from reopened to closed

The current init script expects "option enabled 1" not "option enable 1".

comment:7 Changed 6 years ago by Nilfred <nilfred@…>

r29167 by nico: packages/openvpn: use new service functions, change 'enable' option to 'enabled' like most other services are using

comment:8 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.