Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10506 closed defect (fixed)

MIPS toolchain build fails on OpenSUSE 12.1 (GCC 4.6 - Binutils 2.21.1)

Reported by: Olipro <olipro@…> Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: toolchain Version: Trunk
Keywords: Cc:

Description

Building the toolchain is failing because -lm is not being passed to the host linker; I tried adding this to the rules.mk file but for some reason this wasn't enough for some of the toolchain components and I thus had to add it directly to some Makefiles.

I'm not entirely sure when the change took place, but as far as I am aware, the problem is essentially that under previous versions of GCC/binutils, it was sufficient to specify -lstdc++ to get the lm linked implicitly and this behaviour has now changed to require all libraries that should be linked to be stated explicitly.

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by Olipro <olipro@…>

Update: the change to HOST_LDFLAGS in rules.mk does work providing a make dirclean is performed afterwards.

comment:2 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r29721

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.