Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10498 closed defect (duplicate)

VLAN's on ixp4xx

Reported by: anonymous Owned by: kaloz
Priority: normal Milestone: Chaos Calmer 15.05
Component: kernel Version: Backfire 10.03.1 RC6
Keywords: Cc:

Description

Hi,

i'm trying to enable vlan's on WG302v1. There is only one interface and so i used following configuration:

# Copyright (C) 2006 OpenWrt.org

config interface loopback

option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan

option ifname eth0.100
option type bridge
option proto static
option ipaddr 10.0.0.254
option netmask 255.255.252.0

Interfaces are coming up without any problems, but packets are not tagged. When i connect the WG302 to a cisco switch i only get runts on the trunk interface.

Here is the ifconfig of my configuration.

br-lan Link encap:Ethernet HWaddr 00:0F:B5:DF:2F:08

inet addr:10.0.0.254 Bcast:10.0.3.255 Mask:255.255.252.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:402 (402.0 B)

eth0 Link encap:Ethernet HWaddr 00:0F:B5:DF:2F:08

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:122 errors:0 dropped:0 overruns:0 frame:0
TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:32391 (31.6 KiB) TX bytes:406 (406.0 B)

eth0.100 Link encap:Ethernet HWaddr 00:0F:B5:DF:2F:08

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:406 (406.0 B)

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

This problem exists with kamikaze and backfire rc6.

Thanks in advance,
regards
Herbert

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by kloana@…

Hi,

this is a duplicate of Ticket #7945. On my WAG302v1 this problem also exists on eth0 (NPE-B). For my WAG302v1 i compiled a new ixp4xx package. I changed following settings as mentioned in the ticket above:

  • Comment out line #27:

#define IX_NPEDL_NPEIMAGE_NPEA_ETH_SPAN_FIREWALL_VLAN_QOS_HDR_CONV

  • Uncomment line #29:

#define IX_NPEDL_NPEIMAGE_NPEA_ETH_LEARN_FILTER_SPAN_FIREWALL

The above solution is documented at following link:
http://lists.gateworks.com/avila/2010-September.txt

For me now everything is working flawless.

In the ticket above nbd wrote you could not switch to ETH_LEARN_* because of problems with stp and bridging. Can you explain this a little bit in detail, because i mentioned no problem on my system with stp and bridging?

Thanks in advance,
regards
Herbert

comment:2 Changed 6 years ago by kloana@…

Above solution was done not only for NPE-A. I did it for also for NPE-B and NPE-C.

Comment out line #27:
#define IX_NPEDL_NPEIMAGE_NPEA_ETH_SPAN_FIREWALL_VLAN_QOS_HDR_CONV

Uncomment line #29:
#define IX_NPEDL_NPEIMAGE_NPEA_ETH_LEARN_FILTER_SPAN_FIREWALL

comment:3 Changed 6 years ago by jow

  • Owner changed from developers to kaloz
  • Status changed from new to assigned

comment:4 Changed 6 years ago by nbd

  • Resolution set to duplicate
  • Status changed from assigned to closed

see #7945

comment:5 Changed 4 years ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.