Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10437 closed defect (fixed)

AR7: ethernet does not work in 10.3.1-rc6

Reported by: linux@… Owned by: florian
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Backfire 10.03.1 RC6
Keywords: Cc:

Description

10.3 works fine on D-Link DSL-564T (AR7, IP175A switch), using precompiled openwrt-ar7-squashfs.bin. But with 10.3.1-rc6, the ethernet is dead.

good:

cpmac: device eth0 (regs: 08612800, irq: 41, phy: 0:01, mac: ...)
cpmac: device eth1 (regs: 08610000, irq: 27, phy: 0:00, mac: ...)

bad:

cpmac: device eth0 (regs: 08612800, irq: 41, phy: 1:00, mac: ...)
cpmac: device eth1 (regs: 08610000, irq: 27, phy: 1:1f, mac: ...)

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by jow

  • Owner changed from developers to florian
  • Status changed from new to assigned

comment:2 Changed 6 years ago by v-fox

same for D-Link DSL-500T and it, probably, got broken quite some time ago: i've found revision 24045 also affected, from what i remember.

comment:3 Changed 6 years ago by v-fox <virtuousfox@…>

and this looks to be a duplicate of issue #9565

most likely entire AR7 model line-up with CPMAC networking is like that. i would suggest raising priority and not let this issue rot for another half a year or more.

comment:4 Changed 6 years ago by florian

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with r29241.

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.