Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10422 closed defect (duplicate)

Root password not set correctly (SSH and LuCI)

Reported by: anonymous Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

I've done a fresh install of Openwrt trunk r28108 on my RouterStation Pro and when I set the root password (telnet to the router and then passwd), the password is not set correctly. If I access the router via LuCI, it keeps saying that the password is not set. If I set it in LuCI, the message will occur again and again (the http access continues without password!). SSH will not work, whether i set the password via telnet or via LuCI, it always say Permission denied (publickey, password).

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by jow

  • Resolution set to duplicate
  • Status changed from new to closed

Make sure busybox shadow password is enabled in your .config, clean base-files and busybox, do not restore old backups or revert /etc/passwd and /etc/shadow to rom versions. Also this is a dupe of #10393, #10412

comment:2 Changed 6 years ago by hnyman <hannu.nyman@…>

@jow:
could you please consider enabling the dependency on CONFIG_BUSYBOX_CONFIG_FEATURE_SHADOWPASSWDS either for busybox or base-files.

As the code change in r28936 practically removed the option to not use shadow passwords, it might be enforced through a dependency (and not just left for users). Rebuilding .config is not that usual task for users, and this change requires either that or manually checking the option (as the usual clean task is not enough).

I forecast that there will be a steady stream of duplicate tickets when people run into this issue. So please consider enforcing that option.

comment:3 Changed 6 years ago by jow

No I will not add such a dependency. This is trunk, people building trunk are supposed to know what they're doing and be able to track its development. There are indefinite ways to shoot yourself in the foot, you can for example also deselect libc and build such an image, yet nobody demands that we add a dependency to libc in every single package.

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.