Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10412 closed defect (duplicate)

cannot login via ssh after telnet passwd first login..

Reported by: daniel.petre@… Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

hello,
so i flashed a customized build of r29004 to a tp-link wr703n ,
after first reboot managed to telnet on 192.168.1.1 and change password with "passwd" but ssh won't let me in.

managed to reset it to defaults via "restorefactory" package, telnet again and passwd and tried ssh-ing while logread -f which says:

Sep 8 18:46:49 wr703n authpriv.warn dropbear[4003]: User 'root' has blank password, rejected

here's /etc/passwd after passwd first change:

root:$1$2YdPSS7r$F3rA8AjJbFLhqcvUZW164.:0:0:root:/root:/bin/ash
daemon:*:1:1:daemon:/var:/bin/false
ftp:*:55:55:ftp:/home/ftp:/bin/false
network:*:101:101:network:/var:/bin/false
nobody:*:65534:65534:nobody:/var:/bin/false

Attachments (0)

Change History (4)

comment:1 follow-up: Changed 6 years ago by anonymous

Same as #10405?

comment:2 in reply to: ↑ 1 Changed 6 years ago by hnyman <hannu.nyman@…>

Replying to anonymous:

Same as #10405?

Probably. And also #10393 is about the same issue.

The developers changed base-files code to require "shadow passwords", and changed the defaults for new configs, but they did not force the shadow password support on for all old configs.

You have to either build .config from scratch or change the option by hand. Check if CONFIG_BUSYBOX_CONFIG_FEATURE_SHADOWPASSWDS is enabled in your .config:

menuconfig > Base system > busybox > Login/Password Management Utilities > Support for shadow passwords.

comment:3 Changed 6 years ago by jow

  • Resolution set to duplicate
  • Status changed from new to closed

dupe of #10405

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.