Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10408 closed defect (duplicate)

radvd poll error: Interrupted system call

Reported by: kd4yal@… Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

r28993 WZR-HP-AG300H

daemon.info radvd[2146]: attempting to reread config file
daemon.info radvd[2146]: resuming normal operation
daemon.info radvd[2146]: attempting to reread config file
daemon.info radvd[2146]: resuming normal operation
daemon.info radvd[2146]: attempting to reread config file
daemon.info radvd[2146]: resuming normal operation
daemon.err radvd[2146]: poll error: Interrupted system call
daemon.info radvd[2146]: attempting to reread config file
daemon.info radvd[2146]: resuming normal operation
daemon.info radvd[2146]: attempting to reread config file
daemon.info radvd[2146]: resuming normal operation
daemon.info radvd[2146]: attempting to reread config file
daemon.info radvd[2146]: resuming normal operation
daemon.err radvd[2146]: poll error: Interrupted system call
daemon.info radvd[2146]: attempting to reread config file
daemon.info radvd[2146]: resuming normal operation

Attachments (1)

daemon error.txt (311 bytes) - added by anonymous 6 years ago.
error found in ADSL modem router . any idea what it refers to

Download all attachments as: .zip

Change History (10)

comment:1 Changed 6 years ago by jow

Does it cause any issues? If not it is harmelss and most likely caused by a SIGHUP emitted whenever an interface changes.

comment:2 Changed 6 years ago by kd4yal@…

I also noticed this in the IP6 routing table and thought maybe they are related.

unreachable default dev lo metric -1 error -128
ff00::/8 dev br-lan metric 256
ff00::/8 dev eth1 metric 256
unreachable default dev lo metric -1 error -128

comment:3 Changed 6 years ago by jow

No it is unrelated, so are there any actual problems with radvd?

comment:4 Changed 6 years ago by kd4yal@…

Not that I have noticed as of yet other then the system log being over run with these messages.

comment:5 Changed 6 years ago by hnyman <hannu.nyman@…>

duplicate of #9879

I haven't noticed any material effects, so most likely just log spam.

comment:6 Changed 6 years ago by keeganquinn@…

Shortly after an OpenWrt router here rebooted, I noticed I wasn't receiving IPv6 router advertisements on a client system. Checked on the router, and everything looks fine except for these messages:

Dec 1 00:00:29 k daemon.err radvd[1000]: poll error: Interrupted system call

Restarted radvd and the message no longer appears, and IPv6 router advertisements are once again being sent.

So, these might not simply be "log spam" after all.

comment:7 Changed 6 years ago by jow

  • Resolution set to duplicate
  • Status changed from new to closed

See #9879

Changed 6 years ago by anonymous

error found in ADSL modem router . any idea what it refers to

comment:8 Changed 6 years ago by anonymous

Line
1 daemon.info.radvd (326) ver 0.9.1 started
2 daemon.info.radvd (326) vlan1 is not up
3 daemon.info.radvd (326) inteface vlan 1 does not exist
4 daemon.info.radvd (326) error pashing or activating the config file/temp/radvd
5 daemon.info.dnsmacq(338) started ,
6 daemon.warn DNSmasq(338) failed to drop route privs

comment:9 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.