Opened 6 years ago

Closed 6 years ago

Last modified 2 years ago

#10405 closed defect (invalid)

Sysupgraded from trunk r28879 to r28963, can't log in anymore

Reported by: duvi Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:


It seems that the password related changes broke something. Trying to login through SSH, but the password I set and used with 28879 is not accepted anymore.

Attachments (0)

Change History (11)

comment:1 Changed 6 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed

If it is a custom build, make sure to clean base-files and ensure that shadow password support is enabled in busybox. If it is a snapshot build, revert your configuration (or just /etc/passwd, /etc/shadow back to their /rom version) and set a new password.

comment:2 Changed 6 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I have a similar problem with no password being accepted.
It is a custom build on RSPro, have done a make dirclean, done sysupgrade without keeping the config files. Once flashed, go to passowrd screen, save & apply new password correctly, messages gomes back that new password saved, but warning message remain that "No password set!"

Have tried to change password from both serial and IP attached telnet, no success. Symptoms remain exactly the same..

comment:3 Changed 6 years ago by jow

  • Resolution set to worksforme
  • Status changed from reopened to closed

YOu must also enable shadow password support in your .config.

comment:4 Changed 6 years ago by jow


comment:5 Changed 6 years ago by dimitris@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

It seems that /etc/shadow is not included in the default list of files for sysupgrade, whereas it was either included or not needed previously. I had not added it to my /etc/sysupgrade.conf until now and haven't had any problems upgrading until today.

I just upgraded a WZR-HP-AG300H from trunk r28601 to trunk r29045, both "official" builds from Here's the upgrade session:

BusyBox v1.19.2 (2011-10-26 16:27:57 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 ATTITUDE ADJUSTMENT (bleeding edge, r28601) ----------
  * 1/4 oz Vodka      Pour all ingredients into mixing
  * 1/4 oz Gin        tin with ice, strain into glass.
  * 1/4 oz Amaretto
  * 1/4 oz Triple sec
  * 1/4 oz Peach schnapps
  * 1/4 oz Sour mix
  * 1 splash Cranberry juice
root@maytag:~# cd /tmp
root@maytag:/tmp# sysupgrade -v openwrt-ar71xx-generic-wzr-hp-ag300h-squashfs-sysupgrade.bin 
Saving config files...
Switching to ramdisk...
Performing system upgrade...
Unlocking firmware ...

Writing from <stdin> to firmware ...     
Appending jffs2 data from /tmp/sysupgrade.tgz to firmware...TRX header not found
Error fixing up TRX header

Writing from <stdin> to firmware ...     
Upgrade completed
Rebooting system...

After that I could no longer log in. I applied failsafe and reset the password. Everything seems fine now config-wise.

Here's my /etc/sysupgrade.conf:

## This file contains files and directories that should
## be preserved during an upgrade.

# /etc/example.conf
# /etc/openvpn/

comment:6 Changed 6 years ago by dimitris@…

Ah, as of r29045 /etc/shadow is included in the default sysupgrade files. Without adding it to my /etc/sysupgrade.conf:

root@maytag:/tmp# sysupgrade -v openwrt-ar71xx-generic-wzr-hp-ag300h-squashfs-




So this is a one-off problem, sorry about the noise.

comment:7 Changed 6 years ago by jow

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:8 Changed 6 years ago by Valent Turkovic <valent.turkovic@…>

This is still an issue in current trunk! When will it be fixed?

comment:9 Changed 6 years ago by Valent Turkovic <valent.turkovic@…>

What is the workaround? Is enough to put router in recovery mode and delete passwd and shadow files?

I tried putting router in recovery mode and issuing passwd to create new password, it looked like it worked but still after reboot new password wasn't accepted ;(

comment:10 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:11 Changed 2 years ago by

Experienced this on a Buffalo WZR-600DHP upgrading from stock firmware to Barrier Breaker 14.07(*). I was able to work around the issue via:

  • Uploaded my public ssh key. (System>Administration>SSH-KEYS), then "Save & Apply".
  • ssh to root@<router_ip>, using pubkey authentication
  • run "passwd" to set root's password (to same as web interface).

Once root's password is set the dialog will go away. I logged out of, then back into the web interface, but not sure if that was needed.


Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.