Modify

Opened 6 years ago

Closed 3 years ago

#10403 closed defect (worksforme)

Collectd related errors in recent trunk (28943)

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: rrdtool statistics collectd Cc:

Description

Upgraded trunk to 28943, this is a WNDR3700v1 which has the LUCI-statistics package enabled, which brings in collectd and rrdtool1, which it seems were modified recently.

System log now has these following errors (and there is indeed no /etc/collectd directory at all in the old configuration, there is, however, an /etc/collectd.conf file.)

Nov 11 18:49:59 OpenWrt user.info sysinit: configfile: stat (/etc/collectd/conf.d) failed: No such file or directory
Nov 11 18:49:59 OpenWrt user.info sysinit: Could not find plugin iptables.
Nov 11 18:49:59 OpenWrt user.info sysinit: Could not find plugin processes.
Nov 11 18:49:59 OpenWrt user.info sysinit: Could not find plugin tcpconns.
Nov 11 18:49:59 OpenWrt user.info sysinit: Found a configuration for the `tcpconns' plugin, but the plugin isn't loaded or didn't register a configuration callback.
Nov 11 18:49:59 OpenWrt user.info sysinit: Found a configuration for the `tcpconns' plugin, but the plugin isn't loaded or didn't register a configuration callback.
Nov 11 18:49:59 OpenWrt user.info sysinit: Found a configuration for the `tcpconns' plugin, but the plugin isn't loaded or didn't register a configuration callback.
Nov 11 18:49:59 OpenWrt user.info sysinit: rrdtool plugin: RRASingle = true: creating only AVERAGE RRAs
Nov 11 18:49:59 OpenWrt user.info sysinit: Could not find plugin cpu.
Nov 11 18:49:59 OpenWrt user.info sysinit: Could not find plugin exec.
Nov 11 18:49:59 OpenWrt user.info sysinit: Found a configuration for the `exec' plugin, but the plugin isn't loaded or didn't register a configuration callback.
Nov 11 18:49:59 OpenWrt user.info sysinit: Found a configuration for the `exec' plugin, but the plugin isn't loaded or didn't regi

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by AndrewSi@…

Sorry, meant to add my email to the original ticket.

comment:2 Changed 6 years ago by anonymous

Digging around it seems that I don't have these plugins selected in my build. Is it trying to load these because it can't find its normal config file?

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:4 Changed 3 years ago by hnyman

This bug from 2011 is most likely invalid: caused by config enabling plugins that are missing from the build. It should be closed with "worksforme".

comment:5 Changed 3 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.