Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10395 closed defect (fixed)

miniDLNA restart does not work properly

Reported by: Cypher Owned by: nico
Priority: low Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: minidlna restart Cc:


When executing "/etc/init.d/minidlna restart" it tries to stop minidlna but immediately starts it again.
So while minidlna is being killed by stop(), the function start() is already executed and returns "minidlna is already running" because it wasn't killed yet by stop().

Short version: There needs to be a short delay between stop() and start() or minidlna won't restart.

I tried adding "sleep 1" to stop() and it works now for me! :)

stop() {
	$SSD -p $PID -K -s SIGINT
        sleep 1

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by jow

Arbritary delays tend to break again on slower devices, we'll need to rewrite it to use service wrappers.

comment:2 Changed 6 years ago by Cypher

Oh okay.
The same happened to uShare too, btw.

comment:3 Changed 6 years ago by nico

  • Owner changed from developers to nico
  • Status changed from new to accepted

comment:4 Changed 6 years ago by nico

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in r29174

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.