Modify

Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#10391 closed defect (fixed)

XML Parsing Error in Luci interface

Reported by: Rolf Leggewie <dev.openwrt.org@…> Owned by:
Priority: normal Milestone: Backfire 10.03.1
Component: luci Version: Backfire 10.03.1 RC5
Keywords: Cc:

Description

using RC6 on a bcm47xx device

In the luci interface go to "Network - Wifi" and click on scan. You should get an XML parsing error.

XML Parsing Error: not well-formed
Location: http://192.168.49.1/cgi-bin/luci/;stok=253f0b87243b419ff4c7ebf37224ac6a/admin/network/wireless_join?device=wl0
Line Number 138, Column 57:
	/usr/lib/lua/luci/dispatcher.lua:195: in function </usr/lib/lua/luci/dispatcher.lua:194></pre>
---------------------------------------------------------------^

Attachments (1)

wireless_join.htm (4.9 KB) - added by Rolf Leggewie <dev.openwrt.org@…> 6 years ago.
the error page in question

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by Rolf Leggewie <dev.openwrt.org@…>

the error page in question

comment:1 Changed 6 years ago by Rolf Leggewie <dev.openwrt.org@…>

I asked for confirmation in IRC and soma was kind enough to test but failed to verify the problem. He mentioned the possibility of some funny character in the essid of a neighboring cell wreaking havoc and indeed I have two AP with both spaces and ' in their essid. I unscrewed the antenna on the device to drop out of their reach. "iwinfo wlan0 scan" no longer listed them, but the problem in luci persisted.

comment:2 Changed 6 years ago by Rolf Leggewie <dev.openwrt.org@…>

I'm very sorry to say but this was again a false alarm as I learned in IRC. I happily flashed from kernel 2.4 to 2.6 today -> bug 8941. What I apparently should have done but didn't is untick the box "Keep settings" when flashing the new firmware via luci. Flashing once more with that box unticked I am now able to successfully scan the wifi network.

My apologies for the noise.

comment:3 Changed 6 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

Caused by incompatible wireless config.

comment:4 Changed 5 years ago by anonymous

rt-n16 r36584 with overlayfs - I have this problem

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.