Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10385 closed defect (fixed)

ath9k: wireless in client wds mode stops working after reinit

Reported by: Erik Fonnesbeck <efonnes@…> Owned by: nbd
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Image built from r28851 with make dirclean before build. (I would have updated to newer first, but there are no relevant changes)

The wireless on my access point (TL-WA901ND) configured in client wds mode only works the first time it connects. If wireless is disconnected or disabled, it no longer works when it is re-enabled or attempts to reconnect. It disconnects on its own usually within 15 to 30 minutes of when it first connected (used to be more stable than that).

When the disconnect occurs, this appears in the log with the repeated part repeating every few seconds:

Sep  8 17:33:53 OpenWrt kern.err kernel: ath: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x42000020 DMADBG_7=0x000286c0
Sep  8 17:33:53 OpenWrt kern.err kernel: ath: Could not stop RX, we could be confusing the DMA engine when we start RX up
Sep  8 17:33:53 OpenWrt kern.info kernel: br-eth: port 2(wlan0) entering forwarding state
Sep  8 17:33:54 OpenWrt kern.debug kernel: wlan0: authenticate with 74:ea:3a:d2:5e:dc (try 1)
Sep  8 17:33:54 OpenWrt kern.debug kernel: wlan0: authenticate with 74:ea:3a:d2:5e:dc (try 2)
Sep  8 17:33:54 OpenWrt kern.debug kernel: wlan0: authenticate with 74:ea:3a:d2:5e:dc (try 3)
Sep  8 17:33:54 OpenWrt kern.debug kernel: wlan0: authentication with 74:ea:3a:d2:5e:dc timed out
Sep  8 17:34:00 OpenWrt kern.debug kernel: wlan0: authenticate with 74:ea:3a:d2:5e:dc (try 1)
Sep  8 17:34:00 OpenWrt kern.debug kernel: wlan0: authenticate with 74:ea:3a:d2:5e:dc (try 2)
Sep  8 17:34:00 OpenWrt kern.debug kernel: wlan0: authenticate with 74:ea:3a:d2:5e:dc (try 3)
Sep  8 17:34:00 OpenWrt kern.debug kernel: wlan0: authentication with 74:ea:3a:d2:5e:dc timed out

By removing the patches from r28772 (and r28809 because it doesn't apply cleanly without the previous patch), both symptoms, the frequent disconnects and the inability to connect on reinit, have disappeared.

Attachments (0)

Change History (11)

comment:1 Changed 6 years ago by nbd

please try applying http://nbd.name/ath9k-stop.patch on a standard trunk and see if it resolves your issues.

comment:2 Changed 6 years ago by Erik Fonnesbeck <efonnes@…>

It still cannot reconnect with that patch applied. I did not check whether it fixed whatever was causing frequent disconnects before going back to my last working image.

comment:3 Changed 6 years ago by irimi@…

I can confirm this !
On TL-WR1043ND there is even no client connection possible since above patches are active !

wlan0: authenticate with 00:04:0e:db:58:af (try 1)
wlan0: authenticate with 00:04:0e:db:58:af (try 2)
wlan0: authenticate with 00:04:0e:db:58:af (try 3)
wlan0: authentication with 00:04:0e:db:58:af timed out
wlan0: authenticate with 00:04:0e:db:58:af (try 1)
wlan0: authenticate with 00:04:0e:db:58:af (try 2)
wlan0: authenticate with 00:04:0e:db:58:af (try 3)
wlan0: authentication with 00:04:0e:db:58:af timed out

After removing above patches (r28772 and r28809) connection problems were gone.

comment:4 Changed 6 years ago by nbd

  • Owner changed from developers to nbd
  • Status changed from new to accepted

please try the latest version to see if it improves things. so far i have been unable to reproduce such issues on any of my hardware, so i have to rely on your test feedback.

comment:5 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from accepted to closed

fixed in r29155

comment:6 Changed 5 years ago by anonymous

Hi, I am having the same issue in r35671. Can someone help me?.

comment:7 Changed 5 years ago by nbd

please provide more details

comment:8 Changed 5 years ago by anonymous

root@OpenWrt:/bin/packages# iw dev wlan0 connect xxxx
[ 295.927886] wlan0: authenticate with 0c:df:a4:9d:51:52
[ 295.939727] wlan0: send auth to 0c:df:a4:9d:xx:xx (try 1/3)
[ 296.192779] wlan0: send auth to 0c:df:a4:9d:xx:xx (try 2/3)
[ 296.470458] wlan0: send auth to 0c:df:a4:9d:xx:xx (try 3/3)
[ 296.865447] wlan0: authentication with 0c:df:a4:9d:51:52 timed out

comment:9 Changed 5 years ago by anonymous

root@OpenWrt:/bin/packages# iw dev wlan0 connect xxxx
[ 295.927886] wlan0: authenticate with 0c:df:a4:9d:51:52
[ 295.939727] wlan0: send auth to 0c:df:a4:9d:xx:xx (try 1/3)
[ 296.192779] wlan0: send auth to 0c:df:a4:9d:xx:xx (try 2/3)
[ 296.470458] wlan0: send auth to 0c:df:a4:9d:xx:xx (try 3/3)
[ 296.865447] wlan0: authentication with 0c:df:a4:9d:51:52 timed out

It's TI wl2xx wifi chip on pandaboard.

comment:10 Changed 5 years ago by nbd

If it's TI wl12xx, it does not have anything to do with this ticket. You should test latest trunk, and if it doesn't work report this bug in Linux upstream.

comment:11 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.