Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10371 closed defect (worksforme)

Can not build on Debian 6.0 "Squeeze" anymore due to EXPORT variables

Reported by: maddes Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: other Version: Trunk
Keywords: Debian Cc:

Description (last modified by maddes)

see comment:5 for the solution and explanation

OS: Debian 6.0 "Squeeze"
Linux: 2.6.32-5-amd64 (amd64, x86_64, x64)
Trunk: r28808
Target platform: Orion Generic

Building from distcleaned or fresh checked out trunk fails for me, since an Debian update.
Maybe someone can help to fix this or at least find the cause of this issue.

  1. Debian Update log:

Only some minor packages where updated since my last builds.

Upgrade: libpam0g:amd64 (1.1.1-6.1, 1.1.1-6.1+squeeze1), libfreetype6:amd64 (2.4.2-2.1+squeeze1, 2.4.2-2.1+squeeze2), libpam-modules:amd64 (1.1.1-6.1, 1.1.1-6.1+squeeze1), libfreetype6-dev:amd64 (2.4.2-2.1+squeeze1, 2.4.2-2.1+squeeze2), libpam-runtime:amd64 (1.1.1-6.1, 1.1.1-6.1+squeeze1), tzdata:amd64 (2011l-0squeeze1, 2011n-0squeeze1)
  1. Error messages from make V=99
    /home/maddes/openwrt/test_uimage_split/include/prereq.mk:12: warning: overriding commands for target `prereq'
    /home/maddes/openwrt/test_uimage_split/target/linux//Makefile:13: warning: ignoring old commands for target `prereq'
    Makefile:13: warning: overriding commands for target `prereq'
    /home/maddes/openwrt/test_uimage_split/include/prereq.mk:12: warning: ignoring old commands for target `prereq'
    Makefile:13: warning: overriding commands for target `clean'
    /home/maddes/openwrt/test_uimage_split/target/linux//Makefile:13: warning: ignoring old commands for target `clean'
    Makefile:13: warning: overriding commands for target `download'
    /home/maddes/openwrt/test_uimage_split/target/linux//Makefile:13: warning: ignoring old commands for target `download'
    Makefile:13: warning: overriding commands for target `prepare'
    /home/maddes/openwrt/test_uimage_split/target/linux//Makefile:13: warning: ignoring old commands for target `prepare'
    Makefile:13: warning: overriding commands for target `compile'
    /home/maddes/openwrt/test_uimage_split/target/linux//Makefile:13: warning: ignoring old commands for target `compile'
    Makefile:13: warning: overriding commands for target `install'
    /home/maddes/openwrt/test_uimage_split/target/linux//Makefile:13: warning: ignoring old commands for target `install'
    Makefile:13: warning: overriding commands for target `menuconfig'
    /home/maddes/openwrt/test_uimage_split/target/linux//Makefile:13: warning: ignoring old commands for target `menuconfig'
    Makefile:13: warning: overriding commands for target `nconfig'
    /home/maddes/openwrt/test_uimage_split/target/linux//Makefile:13: warning: ignoring old commands for target `nconfig'
    Makefile:13: warning: overriding commands for target `oldconfig'
    /home/maddes/openwrt/test_uimage_split/target/linux//Makefile:13: warning: ignoring old commands for target `oldconfig'
    Makefile:13: warning: overriding commands for target `update'
    /home/maddes/openwrt/test_uimage_split/target/linux//Makefile:13: warning: ignoring old commands for target `update'
    Makefile:13: warning: overriding commands for target `refresh'
    /home/maddes/openwrt/test_uimage_split/target/linux//Makefile:13: warning: ignoring old commands for target `refresh'
    make: *** prereq: No such file or directory.  Stop.
    make[4]: *** [prereq] Error 2
    make[3]: *** [target/linux/prereq] Error 2
    make[2]: *** [/home/maddes/openwrt/test_uimage_split/staging_dir/target-_uClibc-0.9.32/stamp/.target_prereq] Error 2
    make[1]: *** [prereq] Error 2
    make: *** [world] Error 2
    

Here's also the .config file I start with after a distclean or fresh checkout:

## DO NOT FORGET TO CALL "make menuconfig" TO GENERATE THE COMPLETE .config FILE
## adopted from nbd's release .config (2009), see http://nbd.name/release-build
## changes: not ALL (also removed luci), added IPv6 support, added symbols
#
CONFIG_TARGET_orion=y
CONFIG_TARGET_orion_generic=y
CONFIG_IPV6=y
CONFIG_KERNEL_KALLSYMS=y

Attachments (1)

.config-target.in (116.6 KB) - added by maddes 6 years ago.
./tmp/.config-target.in

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by maddes

./tmp/.config-target.in

comment:1 Changed 6 years ago by nbd

Did you forget to run make menuconfig or make defconfig after creating your .config?

comment:2 Changed 6 years ago by maddes

Of course not :)

  • make distclean
  • copy .config template
  • make menuconfig
  • make V=99

I also recognized the reason. The target options are not created by ./scripts/metadata.pl so they are missing in ./tmp/.config-target.in (see attachment).
But subtargets and profiles are present.

make menuconfig also gave the corresponding warning:

tmp/.config-target.in:1:warning: config symbol defined without type

comment:3 Changed 6 years ago by maddes

Also reinstalled Debian 6.0 "Squeeze" for amd64/x86_64/x64 with the available 6.0.3 DVD set without using any network mirror, but still got the same problem.

Selected via setup: SSH Server & General system

Installed via aptitude:

asciidoc
binutils
build-essential
bzip2
devio
fastjar
flex
gawk
gettext
intltool
libgtk2.0-dev
libssl-dev
libxml-parser-perl
libz-dev
linux-libc-dev
ncurses-dev
patch
perl-modules
rsync
ruby
subversion
uboot-mkimage
unzip
wget
xsltproc
zip

Perl is:

maddes@devdebian6-amd64:~/openwrt/clean$ perl --version

This is perl, v5.10.1 (*) built for x86_64-linux-gnu-thread-multi
(with 53 registered patches, see perl -V for more detail)

And by the way, no feeds are added, just pure trunk.

comment:4 Changed 6 years ago by maddes

Reason for ./scripts/metadata.pl not creating all entries is because ./tmp/.targetinfo does not contain all entries.

In an old trunk test which compiled fine the file ./tmp/.targetinfo has the following Orion targets:

Source-Makefile: target/linux/orion/Makefile
Target: orion
Target-Board: orion
...
@@
Default-Packages: base-files libc libgcc busybox dropbear mtd uci opkg hotplug2 dnsmasq iptables ppp ppp-mod-pppoe kmod-ipt-nathelper firewall kmod-ath9k kmod-crypto-mv-cesa wpad-mini
Target: orion/generic
Target-Board: orion
...
@@
Default-Packages: base-files libc libgcc busybox dropbear mtd uci opkg hotplug2 dnsmasq iptables ppp ppp-mod-pppoe kmod-ipt-nathelper firewall kmod-ath9k kmod-crypto-mv-cesa wpad-mini
Target: orion/harddisk
Target-Board: orion
...

The currently created ./tmp/.targetinfo has only a single Orion target:

@@
Default-Packages: base-files libc libgcc busybox dropbear mtd uci opkg hotplug2 dnsmasq iptables ppp ppp-mod-pppoe kmod-ipt-nathelper firewall wpad-mini kmod-mac80211-hwsim

Source-Makefile: target/linux/orion/Makefile
Target: orion/generic
Target-Board: orion
Target-Name: Generic
Target-Path: /home/maddes/openwrt/clean
Target-Arch: arm
Target-Arch-Packages: orion
Target-Features: gpio pci squashfs usb
Target-Depends: 
Target-Optimization: -Os -pipe -march=armv5te -mtune=xscale -fno-caller-saves
Linux-Version: 3.0.3
Linux-Release: 1
Linux-Kernel-Arch: arm
Target-Description:
	Build firmware images for Marvell Orion based boards that boot from internal flash.
	(e.g.: Linksys WRT350N v2, Netgear WNR854T, ...)

If I understand correctly than this is Makefile issue.

comment:5 Changed 6 years ago by maddes

  • Description modified (diff)
  • Resolution set to worksforme
  • Status changed from new to closed
  • Summary changed from Can not build on Debian 6.0 "Squeeze" anymore to Can not build on Debian 6.0 "Squeeze" anymore due to EXPORT variables

It was not a Debian issue.

I changed one of my help scripts some weeks ago, that handle copying/renaming and uploading of a new build, to work with exported variables.
These exported variables caused issues with make menuconfig.

One or several of these variable names were responsible:

BOARD
SUBTARGET
PROFILE
BUILDTYPE
IMGTYPE
EXTRA
REV
REVP

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.