Modify

Opened 6 years ago

Closed 3 years ago

#10346 closed defect (moved_to_github)

miniupnpd allows only one external or internal interface.

Reported by: Pilot6 <hanipouspilot@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: miniupnpd firewall Cc:

Description

When there is more that one external interface in zone wan there is no way to configure miniupnp in a right way.
It is more logical to use external and internal firewall zones instead of interfaces.

Attachments (0)

Change History (10)

comment:1 Changed 6 years ago by jow

Patches welcome.

comment:2 Changed 6 years ago by Pilot6 <hanipouspilot@…>

OK. We have 3 days off starting tomorrow ;)

comment:3 Changed 6 years ago by Pilot6 <hanipouspilot@…>

Where is "miniupnpd_add_rules" located? I can't find it.
Patch almost done, but I can't get parameters of this function.

comment:4 Changed 6 years ago by Pilot6 <hanipouspilot@…>

Found sry.

comment:5 Changed 6 years ago by Pilot6 <hanipouspilot@…>

It looked quite simple and I got it working. But the problem is that I am not too well familiar with uci. For some reason firewall state shows interfaces that are not currentlu up in core wan_networks. It seems that it shows that is in config but not what is in reality.
So I could not get it work right using zones instead of ifaces for all cases. To make multiple external interfaces works, but it is not worth the effort. Firewall rules must work with zones.

And for some reason I do not get new configs from upnpd by config_get. Existing config get in a right way, but new are empty. 'Uci show' shows correctly.

comment:6 Changed 6 years ago by salvo

@Pilot6:
Can you post what you've got so far for the patch?

comment:7 Changed 6 years ago by Pilot6 <hanipouspilot@…>

I am not sure I saved anything. I will look next week, when I come home.

The thing is that to get it work in a proper way it is needed to rewrite many scripts from scratch. And there is zero chance for that to be commited unto trunk. Openwrt maintainers are not interested in dual interface at all. And if it is committed someone will need to maintain this functonality, since network scripts are updated a lot. Now they are quite different in trunk cimpared to when I made my attempt.

I am not that much interested in uPnP to maintain it. I do not use it at all, but users keep asking for that.

comment:8 Changed 5 years ago by anonymous

Any progress in this? I also need this.

comment:9 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:10 Changed 3 years ago by jogo

  • Resolution set to moved_to_github
  • Status changed from new to closed

Miniupnpd is now maintained here: https://github.com/openwrt-routing/packages.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.