Modify

Opened 6 years ago

Closed 3 years ago

#10320 closed defect (duplicate)

Layer7 Filter does not work

Reported by: colchaodemola@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Layer 7 filtering is not working.

The module is loaded:

# lsmod | grep layer
xt_layer7 8928 1

The simplest rule never matches.
iptables -A FORWARD -t mangle -m layer7 --l7proto http

Chain FORWARD (policy ACCEPT 10060 packets, 5761K bytes)
num   pkts bytes target     prot opt in     out     source               destination         
1        0     0            all  --  *      *       0.0.0.0/0            0.0.0.0/0           LAYER7 l7proto http 
2      360 21464 TCPMSS     tcp  --  *      pppoe-wan  0.0.0.0/0            0.0.0.0/0           tcp flags:0x06/0x02 TCPMSS clamp to PMTU 

and i am surfing a lot ...

tried bittorrent and other protocols , none of them matches...

bleeding edge, r28527

Attachments (0)

Change History (6)

comment:1 Changed 5 years ago by anonymous

The same with me..

comment:2 Changed 4 years ago by anonymous

Have you solved the problem?

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:4 in reply to: ↑ description Changed 3 years ago by yunbenb520

Did this problem resolved? I found this problem too

comment:5 Changed 3 years ago by anonymous

/ticket/14076.html

broken since forever, no one cares,

comment:6 Changed 3 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.