Modify

Opened 6 years ago

Last modified 4 years ago

#10304 new defect

Compilation error for Xen paravirt target with kmod-pcidev enabled

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: Cc:

Description

Name of xen-platform-pci module changed upstream, here's a patch to fix the issue:

Index: package/kernel/modules/virtual.mk
===================================================================
--- package/kernel/modules/virtual.mk (revision 28637)
+++ package/kernel/modules/virtual.mk (working copy)
@@ -168,7 +168,7 @@

TITLE:=Xen PCI device frontend
DEPENDS:=@TARGET_x86_xen_domu @!LINUX_2_6_30&&!LINUX_2_6_31&&!LINUX_2_6_32&&!LINUX_2_6_36
KCONFIG:=CONFIG_XEN_PCIDEV_FRONTEND

  • FILES:=$(LINUX_DIR)/drivers/xen/platform-pci.ko

+ FILES:=$(LINUX_DIR)/drivers/xen/xen-platform-pci.ko

AUTOLOAD:=$(call AutoLoad,10,xen-pcifront)

endef

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by anonymous

Me too.

And the description is a copy from the netdev description. This should be modifed to say it is the PCI device front end.

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.