Modify

Opened 6 years ago

Closed 2 years ago

#10269 closed defect (fixed)

ar71xx eth1 is not stable

Reported by: Eric Liu <hoveringnowings@…> Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: Cc:

Description

My 'dmesg' is flooding with

eth1: link down
eth1: link up (100Mbps/Full duplex)
eth1: link down
eth1: link up (100Mbps/Full duplex)
eth1: link down
eth1: link up (100Mbps/Full duplex)
}}}.
I have searched for it, and found some tickets regarding this kind of issue but all of them did not help.

Attachments (0)

Change History (32)

comment:1 Changed 6 years ago by Eric Liu <hoveringnowings@…>

A little bit more log:

eth1: link down
eth1: link up (100Mbps/Full duplex)
ath: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x42000020 DMADBG_7=0x000042c0
ath: Could not stop RX, we could be confusing the DMA engine when we start RX up
eth1: link down
eth1: link up (100Mbps/Full duplex)

comment:2 follow-up: Changed 6 years ago by nbd

Which openwrt version are you using?

comment:3 in reply to: ↑ 2 Changed 6 years ago by Eric Liu <hoveringnowings@…>

Replying to nbd:

Which openwrt version are you using?

I am now on trunk.

 ATTITUDE ADJUSTMENT (bleeding edge, r28535) ----------

comment:4 follow-up: Changed 6 years ago by nbd

and what kind of device does this problem show up with?

comment:5 in reply to: ↑ 4 Changed 6 years ago by Eric Liu <hoveringnowings@…>

Replying to nbd:

and what kind of device does this problem show up with?

On both my TP-Link WR741ND 2.0 and D-Link Dir-615 E4

comment:6 follow-up: Changed 6 years ago by nbd

Was it a fresh checkout or did you update? If you updated, try running make target/linux/clean world and then reflash afterwards

comment:7 in reply to: ↑ 6 Changed 6 years ago by Eric Liu <hoveringnowings@…>

Replying to nbd:

Was it a fresh checkout or did you update? If you updated, try running make target/linux/clean world and then reflash afterwards

I downloaded images from snapshots/ar71xx/ folder.

comment:8 Changed 6 years ago by anonymous

i'm using 27335 trunk on tplink 740 v3 without any problem. eth1 is connected to adsl concentrator running pppoe connection

comment:9 Changed 6 years ago by Eric Liu <hoveringnowings@…>

I have updated to the newest version in snapshots/ar71xx/ folder.

ATTITUDE ADJUSTMENT (bleeding edge, r29237)

Here is another few logs:

Sat Nov 19 19:38:48 HKT 2011
eth1      Link encap:Ethernet  HWaddr 84:C9:B2:4D:2B:33  
          inet addr:10.0.230.88  Bcast:10.0.255.255  Mask:255.255.192.0
          UP BROADCAST MULTICAST  MTU:1400  Metric:1
          RX packets:6670550 errors:0 dropped:3147444 overruns:39 frame:0
          TX packets:1815162 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2593357643 (2.4 GiB)  TX bytes:817338203 (779.4 MiB)
          Interrupt:4 

root@hnws-router2:~# date && ifconfig eth1
Sat Nov 19 19:38:51 HKT 2011
eth1      Link encap:Ethernet  HWaddr 84:C9:B2:4D:2B:33  
          inet addr:10.0.230.88  Bcast:10.0.255.255  Mask:255.255.192.0
          UP BROADCAST RUNNING MULTICAST  MTU:1400  Metric:1
          RX packets:6670552 errors:0 dropped:3147446 overruns:39 frame:0
          TX packets:1815162 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2593358569 (2.4 GiB)  TX bytes:817338203 (779.4 MiB)
          Interrupt:4 

The dropped is increasing nearly by 1 for every second.

Nov 19 19:36:08 hnws-router2 kern.info kernel: eth1: link up (100Mbps/Full duplex)
Nov 19 19:36:08 hnws-router2 kern.info kernel: eth1: link down
Nov 19 19:36:10 hnws-router2 kern.info kernel: eth1: link up (100Mbps/Full duplex)
Nov 19 19:36:10 hnws-router2 kern.info kernel: eth1: link down
Nov 19 19:36:12 hnws-router2 kern.info kernel: eth1: link up (100Mbps/Full duplex)
Nov 19 19:36:12 hnws-router2 kern.info kernel: eth1: link down
Nov 19 19:36:14 hnws-router2 kern.info kernel: eth1: link up (100Mbps/Full duplex)
Nov 19 19:36:14 hnws-router2 kern.info kernel: eth1: link down
Nov 19 19:36:16 hnws-router2 kern.info kernel: eth1: link up (100Mbps/Full duplex)
Nov 19 19:36:16 hnws-router2 kern.info kernel: eth1: link down
Nov 19 19:36:18 hnws-router2 kern.info kernel: eth1: link up (100Mbps/Full duplex)
Nov 19 19:36:18 hnws-router2 kern.info kernel: eth1: link down
Nov 19 19:36:20 hnws-router2 kern.info kernel: eth1: link up (100Mbps/Full duplex)
Nov 19 19:36:20 hnws-router2 kern.info kernel: eth1: link down
Nov 19 19:36:22 hnws-router2 kern.info kernel: eth1: link up (100Mbps/Full duplex)
Nov 19 19:36:23 hnws-router2 kern.info kernel: eth1: link down
Nov 19 19:36:25 hnws-router2 kern.info kernel: eth1: link up (100Mbps/Full duplex)
Nov 19 19:36:25 hnws-router2 kern.info kernel: eth1: link down
Nov 19 19:36:27 hnws-router2 kern.info kernel: eth1: link up (100Mbps/Full duplex)
Nov 19 19:36:27 hnws-router2 kern.info kernel: eth1: link down
Nov 19 19:36:29 hnws-router2 kern.info kernel: eth1: link up (100Mbps/Full duplex)
Nov 19 19:36:29 hnws-router2 kern.info kernel: eth1: link down
Nov 19 19:36:31 hnws-router2 kern.info kernel: eth1: link up (100Mbps/Full duplex)
Nov 19 19:36:31 hnws-router2 kern.info kernel: eth1: link down
Nov 19 19:36:33 hnws-router2 kern.info kernel: eth1: link up (100Mbps/Full duplex)
Nov 19 19:36:33 hnws-router2 kern.info kernel: eth1: link down
Nov 19 19:36:35 hnws-router2 kern.info kernel: eth1: link up (100Mbps/Full duplex)
Nov 19 19:36:35 hnws-router2 kern.info kernel: eth1: link down
Nov 19 19:36:37 hnws-router2 kern.info kernel: eth1: link up (100Mbps/Full duplex)
Nov 19 19:36:37 hnws-router2 kern.info kernel: eth1: link down
Nov 19 19:36:39 hnws-router2 kern.info kernel: eth1: link up (100Mbps/Full duplex)
Nov 19 19:36:39 hnws-router2 kern.info kernel: eth1: link down
Nov 19 19:36:42 hnws-router2 kern.info kernel: eth1: link up (100Mbps/Full duplex)
Nov 19 19:36:42 hnws-router2 kern.info kernel: eth1: link down
Nov 19 19:36:44 hnws-router2 kern.info kernel: eth1: link up (100Mbps/Full duplex)
Nov 19 19:36:44 hnws-router2 kern.info kernel: eth1: link down
Nov 19 19:36:46 hnws-router2 kern.info kernel: eth1: link up (100Mbps/Full duplex)
Nov 19 19:36:46 hnws-router2 kern.info kernel: eth1: link down
Nov 19 19:36:48 hnws-router2 kern.info kernel: eth1: link up (100Mbps/Full duplex)
Nov 19 19:36:48 hnws-router2 kern.info kernel: eth1: link down
Nov 19 19:36:50 hnws-router2 kern.info kernel: eth1: link up (100Mbps/Full duplex)

comment:10 Changed 6 years ago by Kamil

I have the same problem on TP-Link TL-WR740N/ND v4 r32130 (trunk). Sometimes WAN interface (eth1) lose ip address. I must click connect to get IP address from modem.

comment:11 Changed 5 years ago by Pavlo <ratatam@…>

I have the same problem on TP-Link TL-WR740N/ND v1 r32643.
eth1 is continuously down and up every few hours (usually every 3 hours, sometimes more or less)
J'll check today newest trunk.

comment:12 Changed 5 years ago by crunchy

The same problem occurs on a Netgear WNDR 3800 with OpenWrt 10.03.1 and 12.09-beta.

When the data rate increases the problems occurs more often (every few seconds). Reducing the MTU did not do any good. If I replace the router with my old LinkSys (White Russian 0.9) everything is fine.

comment:13 Changed 5 years ago by nbd

please try current trunk or 12.09 final

comment:14 Changed 5 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

comment:15 Changed 4 years ago by Petr <petr.mvd@…>

  • Resolution no_response deleted
  • Status changed from closed to reopened

I'm having exactly the same problem on eth0. I'm using TL-WR841ND v8.2 with OpenWrt Attitude Adjustment 12.09:

http://wiki.openwrt.org/toh/tp-link/tl-wr841nd#installing.openwrt.on.tp-link.tl-wr841nd.v8.x

I didn't upgrade, this is the first OpenWrt version I installed on the device. Any workaround or suggestions how I could further diagnose the problem would be appreciated.

comment:16 Changed 4 years ago by unbelll@…

Trunk r41293, dlink dir615e4

Mon Jun 23 10:07:09 2014 kern.info kernel: [140232.320000] eth0: link down
Mon Jun 23 10:07:09 2014 kern.info kernel: [140232.320000] br-lan: port 1(eth0.1) entered disabled state
Mon Jun 23 10:07:09 2014 daemon.notice netifd: Network device 'eth0' link is down
Mon Jun 23 10:07:09 2014 daemon.notice netifd: VLAN 'eth0.2' link is down
Mon Jun 23 10:07:09 2014 daemon.notice netifd: Interface 'iptv' has link connectivity loss
Mon Jun 23 10:07:09 2014 daemon.notice netifd: VLAN 'eth0.1' link is down
Mon Jun 23 10:07:11 2014 daemon.notice netifd: Network device 'eth1' link is down
Mon Jun 23 10:07:11 2014 daemon.notice netifd: Interface 'wan' has link connectivity loss
Mon Jun 23 10:07:11 2014 kern.info kernel: [140233.750000] eth1: link down
Mon Jun 23 10:07:11 2014 daemon.err miniupnpd[3673]: ioctl(s, SIOCGIFADDR, ...): Cannot assign requested address
Mon Jun 23 10:07:11 2014 daemon.err miniupnpd[3673]: Failed to get IP for interface eth1
Mon Jun 23 10:07:11 2014 daemon.warn miniupnpd[3673]: SendNATPMPPublicAddressChangeNotification: cannot get public IP address, stopping
Mon Jun 23 10:07:11 2014 daemon.err miniupnpd[3673]: ioctl(s, SIOCGIFADDR, ...): Cannot assign requested address
Mon Jun 23 10:07:11 2014 daemon.err miniupnpd[3673]: ioctl(s, SIOCGIFADDR, ...): Cannot assign requested address
Mon Jun 23 10:07:11 2014 daemon.err miniupnpd[3673]: ioctl(s, SIOCGIFADDR, ...): Cannot assign requested address
Mon Jun 23 10:07:11 2014 daemon.err miniupnpd[3673]: ioctl(s, SIOCGIFADDR, ...): Cannot assign requested address
Mon Jun 23 10:07:11 2014 daemon.err miniupnpd[3673]: ioctl(s, SIOCGIFADDR, ...): Cannot assign requested address
Mon Jun 23 10:07:11 2014 daemon.err miniupnpd[3673]: ioctl(s, SIOCGIFADDR, ...): Cannot assign requested address
Mon Jun 23 10:07:11 2014 daemon.notice netifd: wan (3496): Received SIGTERM
Mon Jun 23 10:07:11 2014 kern.info kernel: [140234.320000] eth0: link up (1000Mbps/Full duplex)
Mon Jun 23 10:07:11 2014 kern.info kernel: [140234.320000] br-lan: port 1(eth0.1) entered forwarding state
Mon Jun 23 10:07:11 2014 kern.info kernel: [140234.330000] br-lan: port 1(eth0.1) entered forwarding state
Mon Jun 23 10:07:11 2014 daemon.notice netifd: Network device 'eth0' link is up
Mon Jun 23 10:07:11 2014 daemon.notice netifd: VLAN 'eth0.2' link is up
Mon Jun 23 10:07:11 2014 daemon.notice netifd: Interface 'iptv' has link connectivity
Mon Jun 23 10:07:11 2014 daemon.notice netifd: Interface 'iptv' is setting up now
Mon Jun 23 10:07:11 2014 daemon.notice netifd: Interface 'iptv' is now up
Mon Jun 23 10:07:11 2014 daemon.notice netifd: VLAN 'eth0.1' link is up
Mon Jun 23 10:07:11 2014 user.notice firewall: Reloading firewall due to ifup of iptv (eth0.2)
Mon Jun 23 10:07:12 2014 kern.info kernel: [140234.750000] eth1: link up (100Mbps/Full duplex)
Mon Jun 23 10:07:12 2014 daemon.notice netifd: Network device 'eth1' link is up
Mon Jun 23 10:07:12 2014 daemon.notice netifd: Interface 'wan' has link connectivity
Mon Jun 23 10:07:12 2014 daemon.notice netifd: Interface 'wan' is setting up now
Mon Jun 23 10:07:12 2014 user.notice miniupnpd: removing firewall rules for eth1 from zone wan
Mon Jun 23 10:07:13 2014 daemon.notice netifd: wan (3960): udhcpc (v1.22.1) started
Mon Jun 23 10:07:13 2014 daemon.warn dnsmasq[24855]: no servers found in /tmp/resolv.conf.auto, will retry
Mon Jun 23 10:07:13 2014 user.notice miniupnpd: adding firewall rules for eth1 to zone wan
Mon Jun 23 10:07:13 2014 daemon.notice netifd: wan (3960): Sending discover...
Mon Jun 23 10:07:13 2014 daemon.notice netifd: wan (3960): Sending select for 10.100.94.128...
Mon Jun 23 10:07:13 2014 daemon.notice netifd: wan (3960): Lease of 10.100.94.128 obtained, lease time 86400
Mon Jun 23 10:07:13 2014 daemon.notice netifd: Interface 'wan' is now up
Mon Jun 23 10:07:13 2014 kern.info kernel: [140236.330000] br-lan: port 1(eth0.1) entered forwarding state

comment:17 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:18 follow-up: Changed 3 years ago by biergaizi2009@…

Same issue on 841Nv7 with Barrier Breaker.

comment:19 in reply to: ↑ 18 Changed 3 years ago by biergaizi2009@…

Replying to biergaizi2009@…:

Same issue on 841Nv7 with Barrier Breaker.

Just ignore it. It caused by my broken ethernet wire.

comment:20 Changed 3 years ago by anonymous

With the stable 14.07 problem still exists on TL-WR740N 2.4. only on eth1

On wr1043nd v2 everything is ok. So it is not wire problem.

comment:21 Changed 3 years ago by anonymous

it looks like /ticket/19598.html

comment:22 Changed 3 years ago by anonymous

Same here. I am using a TL-WR703n with Barrier Breaker. I feel surprised that there are not many TL-WR703n users complaining.

comment:23 Changed 2 years ago by bigplum@…

I also meet this problem on my TP-Link TL-MR3420 v1, with both Barrier Breaker 14.07 and Chaos Calmer 15.05.

[   24.600000] eth1: link up (100Mbps/Full duplex)
[   24.670000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   24.680000] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[   24.740000] device wlan0 entered promiscuous mode
[   24.740000] br-lan: port 2(wlan0) entered forwarding state
[   24.750000] br-lan: port 2(wlan0) entered forwarding state
[   25.640000] br-lan: port 2(wlan0) entered disabled state
[   25.880000] pppoe-wan: renamed from ppp0
[   26.360000] br-lan: port 2(wlan0) entered forwarding state
[   26.360000] br-lan: port 2(wlan0) entered forwarding state
[   26.370000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   26.410000] br-lan: port 1(eth0) entered forwarding state
[   28.360000] br-lan: port 2(wlan0) entered forwarding state
[   44.880000] random: nonblocking pool is initialized
[  327.490000] eth1: link down
[  328.490000] eth1: link up (100Mbps/Full duplex)
[  331.100000] pppoe-wan: renamed from ppp0
[  550.490000] eth1: link down
[  551.490000] eth1: link up (100Mbps/Full duplex)
[  560.970000] pppoe-wan: renamed from ppp0
[ 1571.490000] eth1: link down
[ 1572.490000] eth1: link up (100Mbps/Full duplex)
[ 1575.130000] pppoe-wan: renamed from ppp0

comment:24 Changed 2 years ago by uysiquebien

This keeps happening as of r47335. I can reliably reproduce it by sending thousands of small packets over TCP. Very rarely the port dies and comes up again immediately, but what usually happens is that it gets caught in a loop of going down and up which is not solved not even by unplugging/plugging the cable, although ifconfig eth0 down;ifconfig eth0 up works.

This on a TL-WR741ND v2.

comment:25 Changed 2 years ago by uysiquebien

I have written this that crashes the port every time.

#!/usr/bin/env python

import socket

TCP_IP = 'xxx'
TCP_PORT = 12345

print("Connecting")
s = socket.socket(socket.AF_INET, socket.SOCK_STREAM)
s.setsockopt(socket.IPPROTO_TCP, socket.TCP_NODELAY, 1)
s.connect((TCP_IP, TCP_PORT))
print("Connected")

while True:
    s.send(b"0123456789")

You just have to have any server that listens for incoming connections, then run this and the port dies.

Last edited 2 years ago by uysiquebien (previous) (diff)

comment:26 Changed 2 years ago by anonymous

Same problem with r46767 on a Buffalo WHR-HP-G300N. Once in a while eth1 gets stuck in a loop and I have to restart the network. Really annoying bug.

comment:27 Changed 2 years ago by anonymous

Tried the script by @uysiquebien but it didn't trigger the issue on my WHR-HP-G300N.

comment:28 Changed 2 years ago by psyke83

I've solved the issue on my device but still in the process of nailing down the exact part of the code to modify. See my last comments of bug #18922.

I'll test out uysiquebien's python script, because it's a PITA to trigger the tx timeout condition (I can only trigger via bittorrent activity, and the time it takes to trigger varies a lot).

comment:29 Changed 2 years ago by bittorf@…

thanks for debugging this and finding a testcase.
it seems these tickets are related:

#6754
#14035
#11217
#18616
#19085
#19579

comment:30 Changed 2 years ago by psyke83

Yes, I think all of those can now be marked as fixed. Since it affected all ar71xx devices, there are probably many more poorly-reported bugs related to internet dropping on ar71xx, such as #21381.

comment:31 Changed 2 years ago by nbd

fixed in r47892, r47895

comment:32 Changed 2 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.