Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10268 closed defect (fixed)

make package/base-files: target pattern contains no %

Reported by: lkml@… Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

echo CONFIG_TARGET_brcm47xx=y > .config; make defconfig; make V=99

[...]
make[3]: Leaving directory `openwrt/package/base-files-network'
make[3]: Entering directory `openwrt/package/base-files'
Makefile:700: *** target pattern contains no `%'.  Stop.
make[3]: Leaving directory `openwrt/package/base-files'
make[2]: *** [package/base-files/compile] Error 2
make[2]: Leaving directory `openwrt'
make[1]: *** [openwrt/staging_dir/target-mipsel_uClibc-0.9.32/stamp/.package_compile] Error 2
make[1]: Leaving directory `openwrt'
make: *** [world] Error 2
Command exited with non-zero status 2

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

This was caused by a colon injected from scripts/getver.sh in a git-svn clone of OpenWrt.
The commits r28604 and r28605 changed the awk pattern to properly extract the svn rev again.

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.