Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10266 closed defect (fixed)

minidlna will not build with libffmpeg-mini

Reported by: antonlacon@… Owned by: nico
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Minidlna will not build using libffmpeg-mini. Builds using libffmpeg-full. My understanding is -mini was meant for use with DLNA servers.

ERROR!  Cannot continue.
The following required libraries are either missing, or are missing development headers:

libavcodec libavformat libavutil 

make[4]: *** [config.h] Error 1

A cursory look at the Makefile didn't reveal anything obvious.

Attachments (1)

libffmpeg-mini-build.patch (831 bytes) - added by antonlacon@… 6 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 6 years ago by nico

  • Owner changed from developers to nico
  • Status changed from new to accepted

Changed 6 years ago by antonlacon@…

comment:2 Changed 6 years ago by anonymous

The libffmpeg-mini-build.patch resolved it for me. I suspect libffmpeg-custom will have a similar problem, but I haven't looked through that variant. Most likely needs some nested IFs depending on options being selected.

comment:3 Changed 6 years ago by nico

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in [28548], thanks!

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.