Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10263 closed defect (obsolete)

Wi-fi device does not come up if one interface is disabled

Reported by: Pilot6 <hanipouspilot@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

config 'wifi-device' 'radio0'
	option 'type' 'mac80211'
	option 'macaddr' '00:18:e7:8c:3f:71'
	option 'country' 'DE'
	option 'hwmode' '11ng'
	option 'htmode' 'HT20'
	list 'ht_capab' 'SHORT-GI-40'
	list 'ht_capab' 'TX-STBC'
	list 'ht_capab' 'RX-STBC1'
	list 'ht_capab' 'DSSS_CCK-40'
	option 'txpower' '19'
	option 'channel' '13'

config 'wifi-iface'
	option 'device' 'radio0'
	option 'network' 'lan'
	option 'mode' 'ap'
	option 'ssid' 'Voxnet'
	option 'encryption' 'psk2'
	option 'key' 'XXXX'
	option 'wpa_group_rekey' '0'
	
config 'wifi-iface'
	option 'device' 'radio0'
	option 'network' 'guest'
	option 'mode' 'ap'
	option 'ssid' 'guest'
	option 'encryption' 'none'
	option 'isolate' '1'
	option 'disabled' '1'

With this config after reboot interface does not come up.
After wifi command it does.

Attachments (0)

Change History (10)

comment:1 Changed 6 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed

This works just fine here.

comment:2 Changed 6 years ago by Pilot6 <hanipouspilot@…>

May be it is because there are 2 radios on DIR-825.
To get the router restart properly I have to put wifi to rc.local. I looked in the script and cant't get how that could be.

comment:3 Changed 6 years ago by Pilot6 <hanipouspilot@…>

  • Resolution worksforme deleted
  • Status changed from closed to reopened

The other radio 5GHz does come up.


config 'wifi-device' 'radio0'
	option 'type' 'mac80211'
	option 'macaddr' '00:18:e7:8c:3f:71'
	option 'country' 'DE'
	option 'hwmode' '11ng'
	option 'htmode' 'HT20'
	list 'ht_capab' 'SHORT-GI-40'
	list 'ht_capab' 'TX-STBC'
	list 'ht_capab' 'RX-STBC1'
	list 'ht_capab' 'DSSS_CCK-40'
	option 'txpower' '19'
	option 'channel' '13'

config 'wifi-iface'
	option 'device' 'radio0'
	option 'network' 'lan'
	option 'mode' 'ap'
	option 'ssid' 'Voxnet'
	option 'encryption' 'psk2'
	option 'key' 'XXX'
	option 'wpa_group_rekey' '0'
	
config 'wifi-iface'
	option 'device' 'radio0'
	option 'network' 'guest'
	option 'mode' 'ap'
	option 'ssid' 'guest'
	option 'encryption' 'none'
	option 'isolate' '1'
	option 'disabled' '1'

config 'wifi-device' 'radio1'
	option 'type' 'mac80211'
	option 'country' 'DE'
	option 'channel' '48'
	option 'macaddr' '00:18:e7:8c:3f:72'
	option 'hwmode' '11na'
	list 'ht_capab' 'SHORT-GI-40'
	list 'ht_capab' 'TX-STBC'
	list 'ht_capab' 'RX-STBC1'
	list 'ht_capab' 'DSSS_CCK-40'
	option 'txpower' '17'
	option 'htmode' 'HT40-'
	option 'distance' '30'
	option 'disabled' '0'

config 'wifi-iface'
	option 'device' 'radio1'
	option 'network' 'lan'
	option 'mode' 'ap'
	option 'ssid' 'Pilot6'
	option 'encryption' 'psk2'
	option 'key' 'XXX'
	option 'wpa_group_rekey' '0'

comment:4 Changed 6 years ago by Pilot6 <hanipouspilot@…>

I fixed it by adding sleep 1 to /etc/ini.d/network

boot() {
	setup_switch() { return 0; }

	include /lib/network
	setup_switch

	/sbin/wifi detect > /tmp/wireless.tmp
	[ -s /tmp/wireless.tmp ] && {
		cat /tmp/wireless.tmp >> /etc/config/wireless
	}
	rm -f /tmp/wireless.tmp
	sleep 1
	grep -qs config /etc/config/wireless && {
		/sbin/wifi up
	}

	scan_interfaces

	local ifc
	for ifc in $interfaces; do
		local proto
		config_get proto "$ifc" proto

		local auto
		config_get_bool auto "$ifc" auto 1

		type "coldplug_interface_$proto" >/dev/null && [ "$auto" = 1 ] && \
			coldplug_interface_$proto "$ifc"
	done
}

comment:5 Changed 6 years ago by Pilot6 <hanipouspilot@…>

It is probably because the config file is long.

comment:6 Changed 6 years ago by jow

Cannot reproduce it on a multi radio device either (wndr3700).

comment:7 Changed 6 years ago by Pilot6 <hanipouspilot@…>

I do not know why, but still there is nothing super specific in my config.
May be wifi detect takes more time than expected or something of that kind.

When guest interfaced is enabled, reboot goes fine.

comment:8 Changed 6 years ago by Pilot6 <hanipouspilot@…>

Exactly this was fixed in r28387. I had a little older build.
So it may be closed.

comment:9 Changed 6 years ago by jow

  • Resolution set to obsolete
  • Status changed from reopened to closed

comment:10 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.