Modify

Opened 6 years ago

Closed 2 years ago

#10222 closed defect (moved_to_github)

python package forces compilation of unnecessary libraries when only python-mini is selected

Reported by: pholland27 (at) gmail.com Owned by: nico
Priority: low Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

if you select only the python-mini package, it will still force the compilation of:
gdbm, expat, openssl, sqlite3 (which in turn forces compilation of ncurses and libreadline), and libffi

these libraries are not ultimately installed on the rootfs (or are ipkgs created for them), just compiled, thereby slowing down the build process unnecessarily

this is a regression from the behavior in 8.09

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by nico

  • Owner changed from developers to nico
  • Status changed from new to accepted

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:3 Changed 2 years ago by nbd

  • Resolution set to moved_to_github
  • Status changed from accepted to closed

python is maintained here: https://github.com/openwrt/packages

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.