Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10210 closed defect (obsolete)

Rdate starts too early.

Reported by: Pilot6 <hanipouspilot@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

I connect to the Internet using openl2tp (interface vpn (ppp0)).
Rdate starts when interface is up. But connection takes some time and only after connection interface is addet to a firewall zone. That causes that rdate can't set time.

Oct 10 14:59:28 OpenWrt user.notice rdate: Failed to sync with time-b.nist.gov
Oct 10 14:59:28 OpenWrt user.notice rdate: Failed to sync with ptbtime2.ptb.de
Oct 10 14:59:28 OpenWrt user.notice rdate: Failed to sync with time-b.nist.gov
Oct 10 14:59:28 OpenWrt user.notice rdate: Failed to sync with ntp.xs4all.nl
Oct 10 14:59:28 OpenWrt user.notice rdate: Failed to sync with ptbtime2.ptb.de
Oct 10 14:59:28 OpenWrt user.notice rdate: Failed to sync with ntp.xs4all.nl
Oct 10 14:59:28 OpenWrt user.notice rdate: Failed to sync with time-a.nist.gov
Oct 10 14:59:28 OpenWrt user.notice rdate: Failed to sync with time-a.nist.gov
Oct 10 14:59:28 OpenWrt user.notice rdate: Failed to sync with ptbtime1.ptb.de
Oct 10 14:59:28 OpenWrt user.notice rdate: No usable time server for vpn found
Oct 10 14:59:28 OpenWrt user.notice rdate: Failed to sync with ptbtime1.ptb.de
Oct 10 14:59:28 OpenWrt user.notice rdate: No usable time server for vpn found
Oct 10 14:59:28 OpenWrt daemon.debug pppd[2540]: Script /etc/ppp/ip-up finished (pid 2699), status = 0x0
Oct 10 14:59:28 OpenWrt user.info firewall: adding vpn (ppp0) to zone wan

Maybe it is better to call rdate not from hotplug.d/iface, but from hotplug.d/firewall.

This also is related to all similar interfaces like pppoe, etc.

Attachments (0)

Change History (6)

comment:1 Changed 6 years ago by Pilot6 <hanipouspilot@…>

Please close it. It is same problem with ip-up.

comment:2 Changed 6 years ago by jow

  • Resolution set to invalid
  • Status changed from new to closed

comment:3 follow-up: Changed 6 years ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:4 in reply to: ↑ 3 Changed 6 years ago by user@…

Replying to anonymous:
/etc/hotplug.d/iface/40-rdate in r28499 still needs work:
If the internet is not up when this script is invoked, all time-servers will be probed one time and rdate will not be daemonized.

-> So if the internet gets powered on again, no attempt on the openwrt box will ever be made to sync the time, because rdate got not daemonized.

It is no solution as suggested to wait for probing time-servers until WAN goes up (it is no bad idea, but does not solve the problem), because the router2 before the router1 openwrt is connected to can be the cause of "no internet", so WAN can be up but "no internet is up" and rdate will never be daemonized as described.

I suggest to wait for sucessfully pinging openwrt.org in the script until probing the time-servers is started, or just probing the time-servers clockwise indefinetly until sucess. (Pinging might not be the best idea, because the firewall might be deliberately configured to block it)

As a a time-server successfully configured for daemonized rdate might become permanently unavailabe, this script should be called again, if syncing the time fails for some configurable time period.

comment:5 Changed 6 years ago by nico

  • Resolution set to obsolete
  • Status changed from reopened to closed

rdate has replaced by ntpd in r28612 & r28613

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.