Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10187 closed defect (invalid)

Aiccu doesn't restart when using PPPoE

Reported by: falstaff Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Backfire 10.03.1 RC5
Keywords: aiccu Cc:

Description

My OpenWRT router is connected to the internet using PPPoE. To create an IPv6 I use aiccu. When the WAN connection is reconnected (either provider initiated or manually) aiccu should restart itself as well.

This should be done with an already existing hotplug rule:
https://dev.openwrt.org/browser/packages/ipv6/aiccu/files/aiccu.hotplug

But the current code doesn't take account for PPPoE WAN interfaces, because they are named something like "pppoe-wan".

This can be easily solved using this code:
[ "$ACTION" = "ifup" ] && [ "{INTERFACE##*-}" = "wan" ] && /etc/init.d/aiccu restart

(Because I looked up that file I also found out that the hotplug rule in trunk makes problem with my setup, thats why I reopened #7629)

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by falstaff

Sorry, I accidentally forgot the enable test, this is the right fix:

[ "$ACTION" = "ifup" ] && [ "{INTERFACE##*-}" = "wan" ] && /etc/init.d/aiccu enabled && /etc/init.d/aiccu restart

comment:2 Changed 6 years ago by falstaff

This bug is invalid, the problem was not the interface, but the enable test faild (the interface name is wan, even when using pppoe...)

comment:3 Changed 6 years ago by acinonyx

  • Resolution set to invalid
  • Status changed from new to closed

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.