Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10186 closed defect (duplicate)

mpd can't load library librt.so.0

Reported by: irimi@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: x86 Cc:

Description

On x86 default system I get the error "mpd can't load library librt.so.0". librt was not build nor selected in build configuration.

For details see output

 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 ATTITUDE ADJUSTMENT (bleeding edge, r28362) ----------
  * 1/4 oz Vodka      Pour all ingredients into mixing
  * 1/4 oz Gin        tin with ice, strain into glass.
  * 1/4 oz Amaretto
  * 1/4 oz Triple sec
  * 1/4 oz Peach schnapps
  * 1/4 oz Sour mix
  * 1 splash Cranberry juice
 -----------------------------------------------------
root@OpenWrt:/# mpd
mpd: can't load library 'librt.so.0'
root@OpenWrt:/# ldd mpd
        libm.so.0 => /lib/libm.so.0 (0xb784f000)
        libfaad.so.2 => /usr/lib/libfaad.so.2 (0xb780f000)
        libcurl.so.4 => /usr/lib/libcurl.so.4 (0xb77c8000)
        libmms.so.0 => /usr/lib/libmms.so.0 (0xb77b9000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb76e0000)
        libid3tag.so.0 => /usr/lib/libid3tag.so.0 (0xb76ce000)
        libz.so.1 => /usr/lib/libz.so.1 (0xb76ba000)
        libvorbisidec.so.1 => /usr/lib/libvorbisidec.so.1 (0xb769e000)
        libFLAC.so.8 => /usr/lib/libFLAC.so.8 (0xb7653000)
        libaudiofile.so.0 => /usr/lib/libaudiofile.so.0 (0xb7632000)
        libmad.so.0 => /usr/lib/libmad.so.0 (0xb761c000)
        libvorbisenc.so.2 => /usr/lib/libvorbisenc.so.2 (0xb7523000)
        libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0xb74fb000)
        libogg.so.0 => /usr/lib/libogg.so.0 (0xb74f4000)
        libasound.so.2 => /usr/lib/libasound.so.2 (0xb742d000)
        libshout.so.3 => /usr/lib/libshout.so.3 (0xb741f000)
        libtheora.so.0 => /usr/lib/libtheora.so.0 (0xb73cd000)
        libspeex.so.1 => /usr/lib/libspeex.so.1 (0xb73b8000)
        libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb73b4000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7398000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb7385000)
        libc.so.0 => /lib/libc.so.0 (0xb7341000)
        libcrypto.so.1.0.0 => /usr/lib/libcrypto.so.1.0.0 (0xb722d000)
        libssl.so.1.0.0 => /usr/lib/libssl.so.1.0.0 (0xb71ea000)
        libdl.so.0 => /lib/libdl.so.0 (0xb71e6000)
        librt.so.0 => not found
        ld-uClibc.so.0 => /lib/ld-uClibc.so.0 (0xb785d000)

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #10182

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.