Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10178 closed defect (duplicate)

package 'less' built against libncursesw; does not pull it as dependency

Reported by: mystica555 Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc: mystica@…

Description

I installed the normal gnu-less because busybox-less is...less than useful to me. Upon installing only 1 singular package of 'less' attempts to run 'less' cause a libncursesw not found error.

root@DarwinAnimeRouter:/etc/config# opkg install less --force-overwrite
Installing less (436-1) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/less_436-1_ar71xx.ipk.
Configuring less.
root@DarwinAnimeRouter:/etc/config# which less
/usr/bin/less
root@DarwinAnimeRouter:/etc/config# diff --help |less
less: can't load library 'libncursesw.so.5'
root@DarwinAnimeRouter:/etc/config# opkg list |grep libncursesw
libncursesw - 5.7-5 - Terminal handling library (Unicode)
root@DarwinAnimeRouter:/etc/config# opkg install libncursesw
Installing libncursesw (5.7-5) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/libncursesw_5.7-5_ar71xx.ipk.
Configuring libncursesw.
root@DarwinAnimeRouter:/etc/config# ldd `which less`
        libncursesw.so.5 => /usr/lib/libncursesw.so.5 (0x2b1ae000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x2b1f2000)
        libc.so.0 => /lib/libc.so.0 (0x2b214000)
        ld-uClibc.so.0 => /lib/ld-uClibc.so.0 (0x2b196000)
root@DarwinAnimeRouter:/etc/config# 

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by swalker

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #9682.

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.