Modify

Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#10147 closed defect (fixed)

[uhttpd] SSL support is not compiled properly

Reported by: dmitry.pankratov@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

The HAVE_TLS compiler flag is only set for uhttpd-tls.c source but not for the main source.

I have attached a patch that solves the problem.

Attachments (1)

uhttpd-ssl.patch (479 bytes) - added by anonymous 6 years ago.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by anonymous

comment:1 follow-up: Changed 6 years ago by mazilo

I am just curious and don't know what your intention is to take out CFLAGS += -DHAVE_TLS from line #52 and put it back by itself in line #11 - #13?

On my package/uhttpd/src/Makefile (just 'svn up' to r28296), I have no problem to compile/build uhttpd package for both BRCM47XX and Marvell platforms.

comment:2 in reply to: ↑ 1 Changed 6 years ago by anonymous

Replying to mazilo:

I am just curious and don't know what your intention is to take out CFLAGS += -DHAVE_TLS from line #52 and put it back by itself in line #11 - #13?

On my package/uhttpd/src/Makefile (just 'svn up' to r28296), I have no problem to compile/build uhttpd package for both BRCM47XX and Marvell platforms.

Well the problem is not with the build (it builds correctly) but handling of the TLS command line options in the main module. If CFLAGS are defined as in the original Makefile the uhttpd.c is compiled WITHOUT the TLS support and therefore the mandatory options (like certificates, etc) are not available.
Moving CFLAGS to the top of the Makefile handles this situation.

comment:3 Changed 5 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed differently in uhttpd2

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.