Modify

Opened 6 years ago

Closed 4 years ago

Last modified 4 years ago

#10113 closed defect (fixed)

txpower on Buffalo WZR-AG-300H

Reported by: talktodaniel@… Owned by: developers
Priority: response-needed Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

prior to the Sept 5 snapshot release I was able to set the txpower on the Buffalo WZR-AG-300H 5ghz radio to 20. The Sept 5 snapshot will not go higher than 17.

Also, I've never been able to get the 2.4ghz radio to go higher than 19 on any snapshot.

Attachments (0)

Change History (56)

comment:1 Changed 6 years ago by talktodaniel@…

sorry, the model should be wzr-hp-ag300h

comment:2 Changed 6 years ago by kd4yal@…

This problem has existed for more then a few months.
I have the same issue same platform "wzr-hp-ag300h".

As a work around I use my own regulatory.bin file.

comment:3 Changed 6 years ago by talktodaniel@…

how high are you able to get the txpower to go with your own regulatory .bin file?

comment:4 Changed 6 years ago by kd4yal@…

It doesn't seem to exceed 19 dBm @ 2.4 GHz and 20 dBm @ 5.7 Ghz.

comment:5 Changed 6 years ago by nbd

please try r28253

comment:6 Changed 6 years ago by kd4yal@…

The 2.4 GHz max output is now 10 dBm the 5.7 Ggz works the same as before.

comment:7 Changed 6 years ago by kd4yal@…

After playing around with this a bit more it look as if something out of sync.

On 2.4 GHz increasing power output to 27 dBm will yeild 19dBm actual output power.

On 5.7 GHz increasing power output to 27 dBm will yeild 20dBm actual output power.

comment:8 Changed 6 years ago by anonymous

tested latest trunk on my wzr-hp-g300nh. in AP mode, setting 22dbm w/US showed 20dbm via iwconfig. setting 23dbm shows 21dbm; this appears to be the max. the hardware is apparently capable of much more, according to fcc docs.
thanks,
-matt

comment:9 Changed 6 years ago by talktodaniel@…

the issue is with the wzr-hp-ag300h, not the wzr-hp g300nh.

comment:10 Changed 6 years ago by talktodaniel@…

i'm very willing to install r28253, if someone can give me a couple pointers on how to get started(applying the patch). usually i can figure these out, but i seem to be stumped on this.

comment:11 Changed 6 years ago by kd4yal@…

I have tested revision 28253 with both wzr-hp-ag300h and the wzr-hp-g300nh.

The issue applies to both platforms.

comment:12 Changed 6 years ago by kd4yal@…

Tested r28260 on wzr-hp-ag300h and issue is resolved.
Tested r28260 on wzr-hp-g300nh and issue is resolved.

comment:13 Changed 6 years ago by nbd

please test r28261 as well, also make sure that setting various power levels manually results in the correct displayed tx power.

comment:14 Changed 6 years ago by anonymous

Wow, fixed already? I wish my enterprise vendors provided this good of service. I'll try to test tonight.

comment:15 Changed 6 years ago by kd4yal@…

Tested r28261 on wzr-hp-ag300h on the first boot power was left at 19dBm and was reported as 19dBm on 2.4GHz radio.

Change the output power to 20dBm and 19dBm was the reported out put.
Change the output power to 18dBm and 18dBm was the reported out put.
Change the output power to 16dBm and 16dBm was the reported out put.
Change the output power to 11dBm and 11dBm was the reported out put.
Change the output power to 9dBm and 9dBm was the reported out put.
Change the output power to 6dBm and 6dBm was the reported out put.
Change the output power to 4dBm and 4dBm was the reported out put.

The 2.4 side seem to be working correct.

The 5 gHz radio came up on first boot as 20 dBm as soon as I drop it to 19dGm it reported 13 dBm.

Change the output power to 19dBm and 13dBm was the reported out put.
Change the output power to 18dBm and 13dBm was the reported out put.
Change the output power to 17dBm and 17dBm was the reported out put.

Worked down the power scale to 2dBm and 3dbm was reported.
I also didn't see much of a change in single strength so I really wonder if the correct power out put is be reported.

Changed back to 20 dBm and 13 dBm reported.
Change to 22dBm and 13dBm reported.

Did not have time to check the wzr-hp-g300nh r28261 but went back to check while it still had r28260. Change to 19dBm and 21dBm was reported. Ran through the power setting down to 8dBm no change.

I will try and recheck the wzr-hp-g300nh with r28261 when time allows.

comment:16 Changed 6 years ago by kd4yal@…

Tested r28261 on wzr-hp-g300nh start at 21dBm reported as 21dBm.
Ran down the power scale all was fine till I got to 4dBm reported as 5dBm.
3,2,1 dBm all reported as 5dBm.

wzr-hp-g300nh seem to work at it should.


comment:17 follow-up: Changed 6 years ago by talktodaniel@…

hmm..well i thought i could test it, but i just can't figure out how to apply the patch. can someone direct me to a howto, something that gives the initial steps of how to apply a patch? i'd like to contribute. i'm a former programmer, currently a network engineer, so i'm very technical, just having trouble figuring out where to start.

thanks-

comment:18 in reply to: ↑ 17 Changed 6 years ago by kd4yal@…

Replying to talktodaniel@…:

hmm..well i thought i could test it, but i just can't figure out how to apply the patch. can someone direct me to a howto, something that gives the initial steps of how to apply a patch? i'd like to contribute. i'm a former programmer, currently a network engineer, so i'm very technical, just having trouble figuring out where to start.

thanks-

http://wiki.openwrt.org/doc/howto/build

comment:19 Changed 6 years ago by talktodaniel@…

thanks for the wiki. i downloaded the latest source. it looks like both patches are in the /trunk/package/mac80211/patches directory. currently compiling the image.

so are both of these patches in the current trunk release?(Sept 19)

comment:20 Changed 6 years ago by talktodaniel@…

actually it looks like r28261 was put in sept 20, so obviously not.

comment:21 Changed 6 years ago by talktodaniel@…

i compiled and installed r28279, which should have included the patches mentioned earlier. i'm still seeing the issue on the 5ghz radio: cannot go above 17dbm no matter what i set it to. Here are my wireless radio configs:

config wifi-device radio0

option type mac80211
option channel 3
option macaddr 4c:e6:76:51:f0:5a
option hwmode 11ng
option htmode HT20
option txpower 27
list ht_capab SHORT-GI-40
list ht_capab TX-STBC
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
#option disabled 1

config wifi-device radio1

option type mac80211
option channel 149
option macaddr 4c:e6:76:51:f0:5b
option hwmode 11na
option htmode HT40+
option txpower 27
option rxantenna 2
option txantenna 2
list ht_capab SHORT-GI-40
list ht_capab TX-STBC
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
#option disabled 1

iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

eth1 no wireless extensions.

br-lan no wireless extensions.

wlan0 IEEE 802.11bgn Mode:Master Frequency:2.422 GHz Tx-Power=19 dBm

RTS thr:off Fragment thr:off
Power Management:on


mon.wlan0 IEEE 802.11bgn Mode:Monitor Tx-Power=19 dBm

RTS thr:off Fragment thr:off
Power Management:on


wlan1 IEEE 802.11bgn Mode:Master Tx-Power=19 dBm

RTS thr:off Fragment thr:off
Power Management:on


wlan2 IEEE 802.11an Mode:Master Frequency:5.745 GHz Tx-Power=17 dBm

RTS thr:off Fragment thr:off
Power Management:on


mon.wlan2 IEEE 802.11an Mode:Monitor Tx-Power=17 dBm

RTS thr:off Fragment thr:off
Power Management:on

comment:22 Changed 6 years ago by talktodaniel@…

after i commented out the txpower 2 and rxpower 2, i was able to get it up to 20dbm if i set it to 27dbm. i tried setting it to 20dbm and it went down to 13 dbm.

comment:23 Changed 6 years ago by talktodaniel@…

sorry, i meant after commented out the txantenna 2 and rxantenna 2 i was able to get it up to 20dbm, if i set it to 27dbm.

comment:24 Changed 6 years ago by talktodaniel@…

let me know what test cases you'd like to see, i can perform them and upload the results.

comment:25 Changed 6 years ago by brady.w.clark@…

Does 28344 contain the relevant patches?

Brand new WZR-HP-AG300H, top tx for 2.4 is 16, and for 5.0 is 15.

iwconfig output:
lo no wireless extensions.

eth0 no wireless extensions.

eth1 no wireless extensions.

br-lan no wireless extensions.

wlan0 IEEE 802.11bgn Mode:Master Frequency:2.462 GHz Tx-Power=16 dBm

RTS thr:off Fragment thr:off
Power Management:on

mon.wlan0 IEEE 802.11bgn Mode:Monitor Tx-Power=16 dBm

RTS thr:off Fragment thr:off
Power Management:on

wlan1 IEEE 802.11an Mode:Master Frequency:5.2 GHz Tx-Power=15 dBm

RTS thr:off Fragment thr:off
Power Management:on

mon.wlan1 IEEE 802.11an Mode:Monitor Tx-Power=15 dBm

RTS thr:off Fragment thr:off
Power Management:on

contents of /etc/config/wireless:
config 'wifi-device' 'radio0'

option 'type' 'mac80211'
option 'channel' '11'
option 'macaddr' '00:24:a5:f0:0e:4c'
option 'hwmode' '11ng'
list 'ht_capab' 'SHORT-GI-40'
list 'ht_capab' 'TX-STBC'
list 'ht_capab' 'RX-STBC1'
list 'ht_capab' 'DSSS_CCK-40'
option 'txpower' '27'
option 'htmode' 'HT40-'
option 'country' 'US'

config 'wifi-iface'

option 'device' 'radio0'
option 'network' 'lan'
option 'mode' 'ap'
option 'ssid' '------'
option 'encryption' 'psk-mixed'
option 'key' '---------'

config 'wifi-device' 'radio1'

option 'type' 'mac80211'
option 'channel' '40'
option 'macaddr' '00:24:a5:f0:0e:4d'
option 'hwmode' '11na'
option 'htmode' 'HT40'
list 'ht_capab' 'SHORT-GI-40'
list 'ht_capab' 'TX-STBC'
list 'ht_capab' 'RX-STBC1'
list 'ht_capab' 'DSSS_CCK-40'
option 'txpower' '17'
option 'country' 'US'

config 'wifi-iface'

option 'device' 'radio1'
option 'network' 'lan'
option 'mode' 'ap'
option 'ssid' '------'
option 'encryption' 'psk-mixed'
option 'key' '---------'

comment:26 Changed 6 years ago by brady.w.clark@…

Same build as in my previous comment.

I have found that no matter what I set the txpower to in /etc/config/wireless, if I set it above 16dBm, I get 16dBm, regardless.

However, if I am on channel 9, I can manually raise the txpower as high as 19dBm once the system has finished booting (iwconfig wlan0 txpower 19). Anything above 19 and it stays at 19. If I am on channel 10 or 11, I cannot get above 16dBm.

comment:27 Changed 6 years ago by Todd Richmond <todd_richmond@…>

Same problem as Brady. I upgraded today to the Oct 4 build hoping power would go up and it dropped instead to 16/13 instead. Setting txpower directly with iwconfig doesn't make a difference - 2.4 is capped at 16 and 5.2 is capped at 13

comment:28 Changed 6 years ago by Todd Richmond <todd_richmond@…>

According to comments above the patch was added 9/20, but the latest OpenWrt Oct 4 build r28363 still has the older driver?

kmod-ath9k - 2.6.39.4+2011-09-14-1

comment:29 Changed 6 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

Based on the comments here, there are multiple issues here:

For those peole (e.g. Todd) that don't get the configured tx power by configuration in /etc/config/wireless alone and have to manually increase it after boot, this issue should be fixed in r28387

As for the others that see too low tx power with any recent version, that's likely your eeprom being calibrated for those specific limits. It may be that the device is transmitting at a higher power than what it shows because it may have been calibrated with a tx power offset. If that is the case, then there's no way for the driver to know that or figure it out, hence it's not a software bug.

So far I see no indication that the driver is interpreting the EEPROM wrong, so if you feel that your tx power is lower than you think it should be, please do *NOT* reopen tx power related tickets unless you have evidence that it's a software issue.

I've seen multiple devices from Buffalo with the same model name showing different tx power limits, and from reading and interpreting the EEPROM data, the driver does the right thing.

comment:30 Changed 6 years ago by bradycl_98258

Okay, hold on a sec. I'll try a new build to see what happens, but I want confirmation that wzr-hp-ag300h hardware caps at 19 from somewhere official or from some command I can type into my router before I believe it for a second. 19?

And I also am not going to buy that any hardware caps the potter at 19 on channel 9, and at 16 on channel 10.

Not re-opening--yet. But you have not explained anything.

comment:31 Changed 6 years ago by Todd Richmond <todd_richmond@…>

Hmmm.... no change at all with the latest release. Still stuck at 16/13 (any channel) and iwconfig cannot increase the txpower on any channel. Before I would see an increase for channel 11, but I couldn't connect on that channel. Now I can't increase any channel, regardless of the frequency width (20/40)

This is on an ag300n. I also have a g300nh that I will try tomorrow

comment:32 Changed 6 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I have the exact same problem of being capped at 16dBm/13dBm for radio0/radio1. I'm on channel 1 and 36 respectively. According to iw, the max power it accepts for both radios on their respective channels are 27dBm and 17dBm, which I'm nowhere near.

nbd, if you believe this is hardware issue. can you let us know how to confirm this on our boxes? Also could you share more info on the various limits on txpower, e.g. the iw channel-based cap, the EEPROM cap you mentioned, and maybe the actual hardware limit. Which one is ultimately capping us at 16/13?

comment:33 Changed 6 years ago by nbd

  • Resolution set to worksforme
  • Status changed from reopened to closed

What you see with iw is the regulatory limit, not the hardware limit. cfg80211 currently does not keep track of the hardware limit for all channels. With the patch that I added a while ago, the displayed tx power (when it's running) will be the real hw limit from the driver's point of view.

As far as I know, there are multiple revisions of this device which have different calibrated tx power limits. I can't tell if the limit that it shows is the actual transmission power or whether the device was calibrated with an offset, but I still haven't seen any indication that there is a driver bug involved that is capping the tx power. There is no way to verify the accuracy of the calibration data without the right equipment.

comment:34 Changed 6 years ago by Todd Richmond <todd_richmond@…>

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Definitely still broken. I now have one of the above problems where txpower is 16 after a reboot, but I can manually raise to 19 from the command line. Anything over 19 is still impossible on any channel. This is new for me, but I'm running recent builds after that patch was added. In my case, the 16 vs 19 power definitely is different as witnessed with a wifi meter app.

comment:35 follow-up: Changed 6 years ago by nbd

please try r29566

comment:36 Changed 6 years ago by kd4yal@…

r29666 on the wzr-hp-ag300h it showed up as wzr-hp-g300nh2 and the radio's didn't
work at all.


r29593 now show up as wzr-hp-ag300h and radios are working again.
On the 2.4 radio the power is set at 19 dBm and is reported as 16dBm.


The 2.4 radio use to work at 19dBm.

The 5 Ghz radio worked at 20dBm and still does.

comment:37 Changed 6 years ago by nbd

used to work at 19dbm in which revision?

comment:38 Changed 6 years ago by nbd

by the way, the wzr-hp-ag300h issue is fixed in latest, but after updating it requires running make target/linux/clean before rebuilding.

comment:39 in reply to: ↑ 35 Changed 6 years ago by anonymous

Replying to nbd:

please try r29566

It breaks txpower init on wndr3700 running backfire r29599.

comment:40 Changed 6 years ago by nbd

how?

comment:41 Changed 6 years ago by anonymous

It happens because txpower init goes after

[ ! "$mode" = "ap" ] || continue

and never runs in this case.

comment:42 follow-up: Changed 6 years ago by nbd

please try r29606

comment:43 in reply to: ↑ 42 Changed 6 years ago by anonymous

It's good now and should be committed to backfire.

comment:44 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

backported in r29607, thanks for testing.

comment:45 Changed 6 years ago by Del

  • Resolution fixed deleted
  • Status changed from closed to reopened

Just got this wzr-hp-ag300h and put r32062 on it. I have played around with the txpower settings, and it seems that the 2.4GHz radio does not go above 15dBm, while the 5GHz radio does not go above 20dBm (on any frequency). That is, the txpower reported by iwconfig does not go above the two values when set higher with iwconfig. Is this normal given the latest fix? Is there any way I can check?

comment:46 Changed 6 years ago by Del <delonly@…>

OK, did some more research, and it seems I am stuck with these txpower limits. Both of these reports:
/ticket/9870.html
http://svn.dd-wrt.com:8000/ticket/2081
indicate that I am hitting a hardware limit on my device, which seems to differ from device to device. The signal on this thing is not excellent, but it is actually decent still.

Doesn't seem like I can close this report, but I believe it should be closed.

comment:47 Changed 6 years ago by todd_richmond@…

This is still broken. I have two AG300H routers and both boot at 16dBm regardless of config value above that. However, iwconfig will increase that to 19dBm so I added that to the user script. I've never seen above 19dBm for any openwrt release in the last 6 months and other comments seem to have the same limit

comment:48 Changed 6 years ago by Del <delonly@…>

I saw one user reporting the txpower fixed in a recent alternative firmware. I checked with latest r32706 of openwrt, but mine seems still to max out on 15/20dBm respectively.
ref. http://forums.buffalotech.com/t5/Wireless/WZR-HP-AG300H-Transmit-power/td-p/60842/page/9
The signal strength is a bit on the low side, and the antennas are not detachable. This makes it a rather serious shortcoming to what otherwise is maybe the most potent openwrt router on the market. Too bad.

comment:49 Changed 5 years ago by nbd

  • Priority changed from normal to response-needed

please try the latest version to see if this is still an issue there.

comment:50 Changed 5 years ago by Del <delonly@…>

Sorry, 15dBm is still the best I can do on the 2.4GHz radio, and 20dBm is still max on the 5GHz radio. I do not have equipment to measure the actual output though. Testing on r33666.

comment:51 Changed 5 years ago by todd_richmond@…

Always the same for me (now on r33288) for two AG300H routers. 19dBm on wlan0 and 13dBm on wlan1.

comment:52 Changed 5 years ago by anonymous

If you change the country code in Linux it allow for more power.. I believe the command is wiconfig set reg BO ( BO is the country code for Bolivia, which gives me more power)

comment:53 Changed 5 years ago by anonymous

iwconfig*

comment:54 Changed 5 years ago by anonymous

I'm on 12.09-rc2 (r36088) and have the same issue. Setting reg to BO doesn't help ( iwconfig is gone but iw works to set the reg).

I also tried jow's hack to allow channels 12 and 13 and txpower up to 30 dBm, still no go.

I posted more here: https://forum.openwrt.org/viewtopic.php?id=45260

comment:55 Changed 4 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

should be fixed in current snapshots

comment:56 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.