Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10079 closed defect (fixed)

Sometimes wifi stops working

Reported by: areisp <pavel@…> Owned by: nbd
Priority: high Milestone: Chaos Calmer 15.05
Component: packages Version: Backfire 10.03.1 RC5
Keywords: Cc:

Description

I don’t know, may be this is the same bug: /ticket/9986.html?

I’m using backfire r28203.

Sometimes my wireless connections just stops working. wifi process still present in ps. Already established connections to my wifi-devices won’t receive packets. If I trying to reconnect them, they cant’t get ip via dhcp.

All works again after router reboot or after launching wifi script (it kills old one).

I think it related only to 802.11n mode because 802.11g works normal now (but i don’t sure in that)

Sorry for google-translate =)

Attachments (2)

wifi_stopped.txt (3.0 KB) - added by areisp <pavel@…> 6 years ago.
wifi_stopped-r28514.txt (3.0 KB) - added by areisp <pavel@…> 6 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 6 years ago by areisp <pavel@…>

Ops, my device is D-Link DIR-615 c2

comment:2 Changed 6 years ago by nbd

When that happens again, please show the output of:
cat /sys/kernel/debug/ieee80211/phy0/ath9k/xmit
cat /sys/kernel/debug/ieee80211/phy0/ath9k/interrupt

Changed 6 years ago by areisp <pavel@…>

comment:3 Changed 6 years ago by areisp <pavel@…>

Output in attached file

comment:4 Changed 6 years ago by nbd

OK, that gives me a good indication of what's going on. Too many frames are buffered in the driver and that blocks new connections. I'll let you know when I have a fix for this issue.

comment:5 Changed 6 years ago by nbd

  • Owner changed from developers to nbd
  • Status changed from new to accepted

comment:6 Changed 6 years ago by nbd

please try the latest version to see if it still happens

comment:7 Changed 6 years ago by areisp <pavel@…>

It happened again in about 20 min of high channel usage with torrents on 802.11n.

Changed 6 years ago by areisp <pavel@…>

comment:8 Changed 6 years ago by anonymous

I have the same problem with Buffalo WZR-HP-G300NH running OpenWrt Backfire 10.03.1-RC6 / LuCI 0.10 Branch (0.10+svn7852)

Is it feasible this has something to do with very low transmit power (7dbm) ? I get an idea it may happen less with higher power but haven't really nailed it down yet.

comment:9 Changed 6 years ago by nbd

please try latest trunk, just committed some more fixes

comment:10 follow-up: Changed 6 years ago by areisp <pavel@…>

All works fine already within 4 hours

comment:11 in reply to: ↑ 10 Changed 6 years ago by areisp <pavel@…>

Replying to areisp <pavel@…>:

All works fine already within 4 hours

In branch r29497

comment:12 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from accepted to closed

comment:13 Changed 4 years ago by anonymous

I know this issue is marked as closed, but I've got the same problem as reported by anonymous above. WZR-HP-G300NH, but I'm running BARRIER BREAKER (Bleeding Edge, r41516). Symptoms are the same -- on wifi, I get no DHCP, connections hang. Wired works fine. Connections will be fine for a day or two and then will hang until the device is restarted. Let me know if I should file a new ticket instead.

here's the cat results requested before:

cat /sys/kernel/debug/ieee80211/phy0/ath9k/interrupt
                   RX:   22867774
                RXEOL:          3
                RXORN:          6
                   TX:   16854843
                TXURN:          0
                  MIB:          0
                RXPHY:          0
                RXKCM:          0
                 SWBA:   18756772
                BMISS:          0
                  BNR:          0
                  CST:       7986
                  GTT:          0
                  TIM:          0
               CABEND:          0
             DTIMSYNC:          0
                 DTIM:          0
               TSFOOR:          0
                  MCI:          0
             GENTIMER:          0
                TOTAL:   56587987

SYNC_CAUSE (all 0)

cat /sys/kernel/debug/ieee80211/phy0/ath9k/xmit
                            BE         BK        VI        VO

MPDUs Queued:             1047         12         0    111933
MPDUs Completed:         49800       4778        24    115994
MPDUs XRetried:            578         15         0      1551
Aggregates:             287073        109         0         0
AMPDUs Queued HW:            0          0         0         0
AMPDUs Queued SW:      9600115      15029        40      5612
AMPDUs Completed:      9548274      10235        16         0
AMPDUs Retried:          47874         81         0         0
AMPDUs XRetried:          2318         13         0         0
TXERR Filtered:            367         20         0        92
FIFO Underrun:               0          0         0         0
TXOP Exceeded:               0          0         0         0
TXTIMER Expiry:              0          0         0         0
DESC CFG Error:              0          0         0         0
DATA Underrun:               0          0         0         0
DELIM Underrun:              0          0         0         0
TX-Pkts-All:           9600970      15041        40    117545
TX-Bytes-All:       2429608157    6727212      3828  12174031
HW-put-tx-buf:            2102        427        19      2134
HW-tx-start:           8983764      14873        40    117545
HW-tx-proc-desc:       8984748      14877        40    117283
TX-Failed:                   0          0         0         0

comment:14 Changed 4 years ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.