Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10070 closed enhancement (fixed)

netatalk 2.2.1 update

Reported by: jake1981 <oskari.rauta@…> Owned by: nico
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: netatalk Cc:

Description

netatalk 2.2.1 adds support for OS X Lion and Time machine, numerous bug fixes and improvements. Been waiting this already for a while and here it is now.

I just changed package version and md5sum to match new download and it seems to compile just fine. Haven't tested it yet, but I assume it works as it generates a package very well..

Attachments (2)

netatalk221.diff (518 bytes) - added by jake1981 <oskari.rauta@…> 6 years ago.
netatalk 2.2.1 diff
netatalk221-2.diff (822 bytes) - added by jake1981 <oskari.rauta@…> 6 years ago.
Fixed configuration, user login works. Tested.

Download all attachments as: .zip

Change History (12)

Changed 6 years ago by jake1981 <oskari.rauta@…>

netatalk 2.2.1 diff

comment:1 Changed 6 years ago by anonymous

Just to be clear, Lion is supported under the 2.1.x branch (as long as dhx2 authentication is enabled), its Time Machine support requires 2.2.x branch.

comment:2 Changed 6 years ago by jake1981 <oskari.rauta@…>

Okay. Anyway, patch that I submitted does not allow other than guest user to login - because for some reason it wants to use shadow that isn't enabled by default. I have made a new diff that fixes this and has been tested to work. Submitting it soon..

Changed 6 years ago by jake1981 <oskari.rauta@…>

Fixed configuration, user login works. Tested.

comment:3 Changed 6 years ago by jake1981 <oskari.rauta@…>

New diff is against trunk, so netatalk221.diff does not need to be applied - only apply netatalk221-2.diff

comment:4 Changed 6 years ago by jake1981 <oskari.rauta@…>

Okay. Tested package that generates by my patch. Works great - for everything, sharing for os x lion (10.7) - and time machine as well. I'll recommend that this patch will be joined with the svn tree.

comment:5 Changed 6 years ago by faralla@…

I can confirm, the patch works. Thanks Jake.

Jake, did you test zeroconf with libahavi? Would be a great help for Time Machine users.

comment:6 Changed 6 years ago by nico

  • Milestone changed from Backfire 10.03.1 to Attitude Adjustment (trunk)
  • Owner changed from developers to nico
  • Status changed from new to accepted

comment:7 Changed 6 years ago by nico

  • Resolution set to fixed
  • Status changed from accepted to closed

Applied in [28478] (with minor modifications), thanks for your contribution!

comment:8 Changed 6 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

nico, sorry, there was one thing missing. The uams_dhx2 must be added to the afpd.conf .

afpd.conf must read:

  • -noddp -uampath /usr/lib/uams -uamlist uams_guest.so,uams_passwd.so,uams_dhx_passwd.so,uams_randnum.so,uams_dhx2.so -passwdfile /etc/netatalk/afppasswd -savepassword -passwdminlen 0 -nosetpassword -defaultvol /etc/netatalk/AppleVolumes.default -systemvol /etc/netatalk/AppleVolumes.system -nouservol -guestname "nobody" -sleep 1 -icon

comment:9 Changed 6 years ago by jow

  • Resolution set to fixed
  • Status changed from reopened to closed

Added in r28483 - thanks!

comment:10 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.